How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

Tan, My westerbeke BEG 12.5 will only run with a heavy load

Customer Question

Hi Tan, My westerbeke BEG 12.5 will only run with a heavy load on it, otherwise it shuts down
Submitted: 1 year ago.
Category: Boat
Expert:  Tan replied 1 year ago.
Hello. Has the generator been sitting unused for awhile? Pull the flame arrestor off the carb and put you hand over the opening slightly will it run at lower speeds now. I think you may have a carburetor issue. When you partially cover the carb it will richen up the fuel mixture.Try this and post back with findings.
Customer: replied 1 year ago.

I didn't mention that it starts and runs fine as long as you hold the warm up switch. If you let go it dies. But if you put a load on it before you let go of the switch it runs fine

Expert:  Tan replied 1 year ago.
Ok that the choke. Try the test I posted earlier this will verify the issue. You can close the choke plate and achieve the same thing as using your hand.
Customer: replied 1 year ago.

I tried it, Didn't make a difference

Expert:  Tan replied 1 year ago.
Do this when you hit the warm up switch do you hear anything in the carb?
Customer: replied 1 year ago.

when you hit the warm up switch the choke is activated

Customer: replied 1 year ago.

and I hear a click

Expert:  Tan replied 1 year ago.
So as long as you hit the choke it will keep running correct?
Customer: replied 1 year ago.

no, as long as I hold the switch it runs, after it starts the choke opens. gen is running fine at that point

Customer: replied 1 year ago.

It maybe over revving

Expert:  Tan replied 1 year ago.
Is the oil level up and is the poil clean? Is it possible it is getting hot? Can you disconnect the oil switch and the temp switch just tpo eliminate these as possible causes.
Customer: replied 1 year ago.

oil and filters are new, I tested temp and oil pressure sensors. Also I believe that if one of these were bad, the gen would not run fine with a load on it

Expert:  Tan replied 1 year ago.
The water pump will priduce more water cooling the temp switch off and the oil pressure will increase with a load. Ok I'm at a loss at this point so I will opt out so another expert can help. I'm just not up on this particular model and I have done what I know to check at this point. Youmay have an issue with the ignition.
Customer: replied 1 year ago.

Ok, thanks Tan

Expert:  Tan replied 1 year ago.
Your welcome.

Related Boat Questions