How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: BMW
Satisfied Customers: 24670
Experience:  Over 17 years diagnosing and repairing vehicles.
14928985
Type Your BMW Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I have a bmw 530xi 2007 my seats control switches don't work

Customer Question

hi I have a bmw 530xi 2007 my seats control switches don't work I just replace them and nothing work but my seat move when I use my scanner with inpa software check all the fuse and they all are ok I don't check the relay because I don't know which one to check or how
Submitted: 3 months ago.
Category: BMW
Expert:  peterpete190 replied 3 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

Inspect the seat switch wiring and wiring connections themselves for any issues.In some cases there may be a fault with the switch wiring or connection that can cause this here with it needing repaired or replaced.If this is or has been checked and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 3 months ago.
Hi I did check all the connections and they are ok
Expert:  peterpete190 replied 3 months ago.

Does your model have memory and heated seats?

Customer: replied 3 months ago.
it does
Expert:  peterpete190 replied 3 months ago.

O.k.,since the wiring is o.k. and the switches were replaced and you can control the seats with the scanner this sounds like the fault with the seat control module itself.I have seen the seat control module fail before needing replaced.The seat switches send signals to the control module and the control module then operates the seats.The circuits in the module can fail to where it does not recognize the commands from the switches.

The modules are attached to the bottom of the seats and the seats usually need removed to replace it.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.Your 5 star rating is appreciated

Thanks Pete

Customer: replied 3 months ago.
The two seat have the same problem
Customer: replied 3 months ago.
When move the bottom of the switches don't do nothing no noise
Expert:  peterpete190 replied 3 months ago.

O.k.,this is both seats.I apologize for that.Unfortunately my diagrams do not cover beyond the seat modules so it is hard to say for sure from here what component is at fault.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Customer: replied 3 months ago.
Did they use any relays