How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: BMW
Satisfied Customers: 26682
Experience:  Over 17 years diagnosing and repairing vehicles.
14928985
Type Your BMW Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Randomly my 2011 535i GT has entire electrical system

Customer Question

Randomly my 2011 535i GT has entire electrical system reboot. Random faults come on for short time. I have had Alternater and CIC unit replaced. Any thoughts?
Submitted: 8 months ago.
Category: BMW
Expert:  peterpete190 replied 8 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Is this acting up as if the ignition was quickly turned off and right back on again or acting up like the battery has been disconnected and then reconnected again quickly?

Can you list all that was or has been checked,tested or replaced for this issue here?

Let me know so we can continue,thanks Pete.

Customer: replied 8 months ago.
Sometimes it just blinks off then back on. Nav and dashboard blink. Other times the Nav acts like the car has just been started.
Alternator and CIC were supposedly getting overcharged so those were both replaced. Had it happen again last week and car actually went into Neutral! I never lost programmed stations or anything like.
Expert:  peterpete190 replied 8 months ago.

I would have the battery cables checked and see if any are found to be loose or corroded or damaged causing this fault here.This needs done to see if anything is found to be loose,damaged or corroded as this will cause this fault here.If this was already checked let me know.Loose or corroded cables cause a poor connection which will cause electronics to reset.I have seen this at the battery,leading from the battery as well as the under hood fuse panel.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete