How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg, Technician
Category: BMW
Satisfied Customers: 6754
Experience:  17 years Shop Owner /Technician. 27 years experience,
Type Your BMW Question Here...
Greg is online now
A new question is answered every 9 seconds

I have an 08 528xi.

Customer Question

I have an 08 528xi. <y wife was driving it and it started overheating. A/C quit blowing cold. I changed the water pump and t stat and purged the system, but still overheating and blowing hot. Fan does not come on with or without the A/C on and even after heating up. Checked all the fuses as well. Any thoughts?
Submitted: 2 months ago.
Category: BMW
Expert:  Steve replied 2 months ago.
Hello and welcome,
My name is ***** ***** it will be my pleasure to assist you today.
I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
Thank you for your attention to the rating requirement.
If the fan never comes on and no fuses are blown then the fan is bad, it is a common failure. There is nothing else in the fan circuit
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.
Customer: replied 2 months ago.
I tried a new fan today w/no luck on that either.
Customer: replied 2 months ago.
12v on one wire at the fan plug, 4.5v on another wire w/no change if a/c is on or off, and then ground.
Expert:  Greg replied 2 months ago.

Hi .

I suggest you have the cooling system check for Co2 this is a test to see if you have a blown headgasket which sounds to me

what your problem maybe if the cooling fan system is functional.

Now when the engine overheats the A/C system will be shut down by the management system so no expensive damage is caused .

In many cases the overcharge valve on the compressor may have opened and dumped the Freon from the system when overheated maybe the reason why you now have no A/C..

This engine is very delicate to overheating and in most cases if overheated to the stage the A/C dumps it freon then

a blown headgasket is very possible and common to happen .

Still need additional information then please get back to me with the reply button, and not the poor or bad service, this way i can get back to you or suggest another expert if needed.

Your deposit does not pay me until the answer is rated in a positive way,
A bad rating does not constitute a refund.

If you are not happy or you have sorted out your problem before the answer then please let me know with the reply button .

Kind regards Greg.

Customer: replied 2 months ago.
The ac levels are still good. I put gauges on it to check. The fan will not kick on. I put a new aux fan in and turned ac on and it still did not turn on.
Expert:  Greg replied 2 months ago.

Do you have the use of a good scan tool ,

Should check for A/C malfunction codes ,and live data so we can check

what is running .

So the fans are not running when A/C is switched on .

Do they come on when the engine reaches 94c .


Customer: replied 2 months ago.
No it does not come on then either. I did not try the new fan with the engine warming up, but did try with just turning the ac on. I have a decent scan tool. No codes showing for ac.
Expert:  Greg replied 2 months ago.

Live data stream for A/C

Customer: replied 2 months ago.
No live stream for a/c. Just let it warm up to 201* and turned a/c on. No fan.
Customer: replied 2 months ago.
I guess I will just take it into the shop. Thank you for the help though.
Expert:  Greg replied 2 months ago.

Hi Brad

You may have a problem with the coolant temp sensor , cooling aux fan relay .

cooling fan fuse have you checked all these possibilities.

Rgds Greg

Customer: replied 2 months ago.
From what I have read there is no relay on this model and I can't find anything on a location of one if there is. I have checked all the fuses. I unplugged the temp sensor and nothing happened as far as the fan turning on.
Expert:  Greg replied 2 months ago.

Brad i will get into my shop pc tomorrow and check this out for you .


Customer: replied 2 months ago.
Thank you.

Related BMW Questions