How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve, BMW Expert
Category: BMW
Satisfied Customers: 22865
Experience:  BMW Expert
Type Your BMW Question Here...
Steve is online now
A new question is answered every 9 seconds

Fixed ABS/ASC lights, ABS is fine, Now Speedo won't Work I

Customer Question

Fixed ABS/ASC lights, ABS is fine, Now Speedo won`t Work
I was getting ABS and ASC lights. NO brake lights. Error was "Abs valve relay error". Speedo an Odometer were working fine. ABS and ASC weren`t working.
It turned out a few pins on the ASC Module got rotten and broke. I sent the Module to repair and they resolder the broken pins.
It came back with both ASC and ABS lights still on and the Speedo now off. After 100 miles ASC/ABS lights went off, but the Speedo still won`t work.
I Rescanned for errors with Inpa and Pa Soft, and the previous "valve relay error" is gone. However now I got some "70 [112] Can Instrument Cluster" error.
1. The speedometer needle is working fine, checked through OBC test 2.
2. The digital speedometer won`t work, but it works through an Inpa test where Inpa send a speed signal to the car to simulate that speed. For example I sent a 60mph signal: the doors locked, came up the "release parking brake warning" and the digital speedometer marked 60mph.
3. All ABS wheel sensors are fine, checked through Inpa.
4. No ABS/ASC lights, Speedometer/ Odometer aren`t working. ASC switch works. ABS Works just fine.
Any inputs on this ?
Submitted: 4 months ago.
Category: BMW
Expert:  Steve replied 4 months ago.

I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.


thank you for your attention to the rating requirement.


the most likely cause is the still the abs module, I would send it back for a do-over.


the only other issue would be a coincidental failure of the cluster or unrelated communication issue - very unlikely relative to the high likelihood of the abs module still being the issue.


Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.

Customer: replied 4 months ago.
Thank your for your quick answer, I did a hard reset and now there are no errors coming from the module. Its a BOSCH ABS/ASC 5.7Servotronic isn`t working, leaving the steering very light all the time. Automatic door locking when driving is not working. All the rest is working fine, including abs and asc, NO lights on the dash.I`m not sure about this being the module, NO Errors and ABS/ASC are good. I have Inpa and Progman installed, do you recommend me to do any tests ?
Expert:  Steve replied 4 months ago.

no there is no testing you can do on a bad module. based on what you have described, and the likelihood of a coincidental other issue, I still say the module is the probable cause.

Please do not forget to CLICK ON a positive rating as this is the only way I receive credit or my time and answer.

Related BMW Questions