How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 23019
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now
A new question is answered every 9 seconds

My dash temperature gauge on my 2007 335i never moves from

Customer Question

My dash temperature gauge on my 2007 335i never moves from 160 degrees (lowest mark on the gauge.)
Submitted: 6 months ago.
Category: BMW
Expert:  Jerry replied 6 months ago.

Hello and welcome. My name is ***** ***** you for visiting the site.

.

Has the thermostat been checked or replaced?

Customer: replied 6 months ago.
No, but it's not a coolant temperature sensor it's a oil temperature sensor. Are you a BMW technician?
Expert:  Jerry replied 6 months ago.

I see, thanks. I am sorry, I had no way of knowing that and unfortunately I don't have anything on it.

I will opt out and open it back up. Please DON’T REPLY to this post as that will lock the question back to me, I’m sure, thanks and sorry I wasn’t able to help with it.

Expert:  Steve replied 6 months ago.

the problem is that the temp sensor is defective or there is a wiring/connection issue. there is no other possibility. Please do not forget to CLICK ON a positive rating as this is the only way I receive credit for my time and answer. as there are two experts involved in this question please take care to positively rate my answer. thank you

Customer: replied 6 months ago.
Wait a minute... That's pretty obvious advice, the kind of advice I'm not willing to pay for. I mean not even a location of where the sensor is? Or any tsb's that could be helpful toward my issue? I am a certified ASE technician, this car was going in and out of limp mode, locking into gear, and slightly overheating; the cause of this was because of a leaking battery. Since the battery was replaced the car now runs and drives fine. Just no oil temp reading, I needed to replace the valve gasket, which I did after it was running again, and the cams and all visable head components looked good. I replaced the value cover and performed an oil change which the same results. The car doesn't seem to be over heating but I have no way of knowing? My scanner doesn't work on BMWs for more detailed testing.
Expert:  Steve replied 6 months ago.

I'm sorry. this is what you posted "My dash temperature gauge on my 2007 335i never moves from 160 degrees (lowest mark on the gauge.) "

I had no idea what you wanted to know, if you were a technician, or anything else. I did my best to provide guidance based on my assessment of what you were looking for.

Expert:  Steve replied 6 months ago.

I will go ahead and opt out of your question as well, perhaps somebody else will be able to help.