How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: BMW
Satisfied Customers: 21598
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your BMW Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 97 bmw 328ic i ran the code and i get engine

Customer Question

i have a 97 bmw 328ic i ran the code and i get for the engine throttle- valve potentiometer
and for the transmission i get can accelerater pedal position. i have replace both senor and still the car rpms go up and down and i loose power and sometime i just want to go and i have to hold the break so it doesnt go. could there be a air leak or some vacuum hose loose.. thank you eddie
Submitted: 8 months ago.
Category: BMW
Expert:  Steve replied 8 months ago.
Hello and welcome,
My name is ***** ***** it will be my pleasure to assist you today.
What are the exact faults you have?
Customer: replied 8 months ago.
throttle-valve potentiometer and the transmission code is canaccelerater pedal position i have replace both senor and still hving the same problem
Customer: replied 8 months ago.
icarsoft 9a and 0c
Customer: replied 8 months ago.
Did u come up with anything
Expert:  Steve replied 8 months ago.
what sensors exactly did you replace?
Customer: replied 8 months ago.
replace both throttle senors
http://www.rockauto.com/info/154/TH316photo%20primary__ra_p.jpg
http://www.rockauto.com/info/31/BA1580864-1__ra_p.jpg
Expert:  sprinkles08 replied 8 months ago.

Hello and welcome to JustAnswer!

If the correct parts were replaced and you're still setting fault codes then the issue is most likely wiring or connection related.

Do you have the actual P code numbers?

Customer: replied 8 months ago.
That's what I get on icarsoft
Customer: replied 8 months ago.
They do clear when I reset them on the computer but after a day of drive the code come back and the car start acting up
Expert:  sprinkles08 replied 8 months ago.

P codes start with a P and have four numbers. Do you have the P codes?

Customer: replied 8 months ago.
Icarsoft don't give p codes
Expert:  sprinkles08 replied 8 months ago.

P codes are the standardized reporting method mandated by the government for all vehicles 1996 and newer. I'll need the actual P code numbers to identify what is setting. Do you have something like an Autozone? Most big chain parts stores will read codes for free.

Customer: replied 8 months ago.
I'll check it tomorrow and let u know
Expert:  sprinkles08 replied 8 months ago.

Ok.

Customer: replied 8 months ago.
I get a p1765 aND p0121
Thank u
Expert:  sprinkles08 replied 8 months ago.

Was any actual testing done?

Do the codes set immediately every time they are cleared? If not, was testing done at the time the codes were active?

Customer: replied 8 months ago.
I went to a junk yard today and got two used sensors I replace them with the new ones I bought online clear the codes took it for a long drive and everything works great to more codes the only thing that is doing now it's when I stop the car starts to idle between half rpm and 1.5 goes up and down no codes come up. Any idea
Expert:  sprinkles08 replied 8 months ago.

Does unplugging the TPS drop the idle back to normal?