How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 23040
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now
A new question is answered every 9 seconds

2000 bmw 528i with abs problem

Customer Question

2000 bmw 528i with abs problem
Submitted: 9 months ago.
Category: BMW
Customer: replied 9 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Steve replied 9 months ago.
hello
what exactly is your question about the abs problem?
Customer: replied 9 months ago.
I did brake on the vehicle abs light came on and no communication with the scanner
Expert:  Steve replied 9 months ago.
you have a scanner that previously could communicate with the abs system?
Customer: replied 9 months ago.
the same one but if I let the vehicle sit for some time I am able to communicate one time I got code 82
Expert:  Steve replied 9 months ago.
I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
that code is for a bad abs sensor on the front right.
however, since you are not getting communication it could also be that the abs module has failed, which is common.
I would replace the sensor and check the wiring/connection and re assess. if the issue persists, I would suspect the module
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.
Customer: replied 9 months ago.
I have replaced the sensor and the wires are good
Expert:  Steve replied 9 months ago.
Please do not forget to CLICK ON a positive rating
then I stated, I would suspect the ABS module is bad
as the question has been answered, please kindly CLICK ON a positive rating
Customer: replied 9 months ago.
After I replaced the sensor drove the car it ran good no light but when I turned the key off and start it after five minutes the light came on when I drove it went off for awhile and came back
Expert:  Steve replied 9 months ago.
that does not change my answer.
what has been described points to the abs module.
as the question has been answered please kindly CLICK ON a positive rating
Expert:  Steve replied 9 months ago.
if there are no additional questions please kindly CLICK ON a positive rating

Related BMW Questions