How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: BMW
Satisfied Customers: 25894
Experience:  Over 17 years diagnosing and repairing vehicles.
14928985
Type Your BMW Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

How are you? I am getting sometimes the 4x4 sign on my X5

Customer Question

Hello! How are you? I am getting sometimes the 4x4 sign on my X5 2004 e53 4.4 v8. After I turn it off for some seconds and back on it goes away. Yesterday I was driving a bit fast and the radio shut off for a bit, the trans fail safe sign turned on and then the 4x4 light and one that is besides it (I don't remember which one) came on as well. I turned it off for some seconds and back on, everything went away and then after driving some miles it came back on... Do you know what the issue might be? Thank you in advance
Submitted: 1 year ago.
Category: BMW
Expert:  peterpete190 replied 1 year ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

When you say the radio shut off did the entire thing power off with no signs of power to it when this occurred?

Let me know so we can continue,thanks Pete.

Customer: replied 1 year ago.
Thank you Pete, the radio just muted
Customer: replied 1 year ago.
Then it came back on
Expert:  peterpete190 replied 1 year ago.

Your welcome

O.k.,low voltage can cause these issues here as I have seen.I have seen issues with a weak battery or alternator cutting out components like this and causing lights to come on as well as loose or corroded battery or alternator cables needing corrected.If these have not been checked to see if any of these are the cause here this needs done.If a fault is found with one of these here this will need corrected to resolve this issue.

If these are found o.k. your next step would be to have the fault codes checked to see what codes are set in all computers in your vehicle.This will require a scan tool or dealers computer plugged into your vehicle to see what codes are set.Once this has been done any codes set will need diagnosed to locate and repair the fault here.

I have seen in some cases where the electronic ignition switch can cause this fault here needing replaced and so this may need tested as well with the proper scan tool to check the signals from it and a multi meter.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 1 year ago.
Thanks hoy very much Pete, makes a lot of sense, probably the alternator, or you think the battery is most probable? Once again thank you, ***** ***** great day.
Expert:  peterpete190 replied 1 year ago.

Your welcome.I have seen both cause a fault like this here before in the past and more common can be the battery not holding enough of a charge but the alternator can also cause this if it isnt providing enough voltage or amperage.I would have these tested here to see if any can be pinpointed as the fault here.

Let me know if you need anything else and feel free to rate my help here.

Thanks Pete