How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin Your Own Question
Kevin
Kevin, BMW Mechanic
Category: BMW
Satisfied Customers: 1771
Experience:  Diagnostic technician
84635724
Type Your BMW Question Here...
Kevin is online now
A new question is answered every 9 seconds

I have a 2002 bmw x5 4.4 that just out of the blue the brake

Customer Question

Good morning. My name is ***** ***** I have a 2002 bmw x5 4.4 that just out of the blue the brake light,abs light and traction light came on. The codes are 90 and 104. I have a snap on scan tool and have tried resetting them also Tryed resetting the angle sensor. Checked the battery connections charged the battery up over night. sometime when I clear the codes and reset the angle sensor the lights will go off for awhile (5 min or so) then come back on other times they come right back on. Also I see on the scanner that the battery voltage to the engine computer is 13.5 when running. But the abs Computor is only saying 11.9-12.1. I don't know if this is normal or why the light are on. Can you please help me fix this problem?
Submitted: 1 year ago.
Category: BMW
Expert:  Steve replied 1 year ago.
Hello and welcome,
My name is ***** ***** it will be my pleasure to assist you today.
What are he code definitions for those codes provided by your code reader? Those are not a common format...
Customer: replied 1 year ago.
The codes are in the abs Computor.
Code 90 intermittent system down
Code 104 steering angle sensor(Ecu)
Customer: replied 1 year ago.
Did you get my last response?
Expert:  Steve replied 1 year ago.
I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
I would check the connections and wiring to the abs module but if everything checks out I would suspect the ABS module itself is faulty
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.
Customer: replied 1 year ago.
Hi I Took apart the ABS connection and it was clean and dry, there was no oil or any type of liquid in there. I still cleaned it with cleaner and use the air compressor to dry it off very good. Then I put it all back together clear the codes and cycled the key several times and the lights did not come back on. Left the truck off for a couple minutes, then restarted it and the lights were back on again. I know you said that it's probably the ABS module, is there any other tests that we could that I could do to verify it is bad or the problem. I don't want to spend all the money for a new module and it does not fix it. Also I think I mentioned before that the battery voltage at the ABS unit the scan tool is saying that it is 11.7 to 12.1 volts. Is this what it is supposed to be? The engine ECM is showing 13 5 to 13.9 Volts
Expert:  Steve replied 1 year ago.
Please do not forget to click on a positive rating
The voltage rating is not right. I suggested a wiring or connection issue or the module as the cause. If you don't think there is any issue with the actual power going to the unit then then unit is bad
I would look into sending it out for repair to bba reman or module masters
Please do not forget to click on a positive rating
Customer: replied 1 year ago.
Is there a fuse that I can check that powers it? Were is the fuse at?
Expert:  Steve replied 1 year ago.
Please do not forget to click on a positive rating
the fuses for ABS are 51 55 and 63 in the glove compartment fuse box. there is very little chance a fuse is the problem. as the question has been answered, please kindly CLICK ON a positive rating
Customer: replied 1 year ago.
hi steve well i took the abs module off sent it out to have it checked and rebuilt got it back yesterday and put it back on the truck reset the lights, they were off for about a min and then come back on. so it is was not the module. i feel i wasted money sending the unit out to have it rebuilt as you said was the problem. so know what should i do? there is no test procedures to do like i originally ask for to check and find out what the problem is?
Expert:  Kevin replied 1 year ago.

Hi im kevin sorry to hear of your ongoing trouble lets start from the beginning and i or another tech may be able to get this sorted for you .these lights came on whilst driving ?what tests have you carried out ? How are you reading codes ?

Customer: replied 1 year ago.
Hi Kevin. What is going on. It was probably the coldest day of the year here in Chicago, I got out of the Offic went to the truck and turned the key to start it, it started and chugged die out. So I started it again and then the light ( abs brake light and the triangle light were on). So I took it to my friend that has a snap on solsius scan tool had the two codes 90 and 104. So I ask the last guy what the procedures were to check it and he basically said it was the abs modlule. So I sent it out to be rebuilt checked. Got it back installed it and had the steering angle sensor reset and the lights turned off. They stayed off for over 10 min. Turning the key on and off several times. Then as soon as I went to drive the truck and turned the wheel a little bit the lights all came back on again. So we reset everything again. The lights stayed off for several key cycles again. But as soon as I started driving the truck again the lights came on again. I have checked all the fuses and all are ok. Is there any other test procedures I can do to find out what is wrong? The last guy I was dealing with said it was a bad module and I feel I waisted all that money to take it off and send it out and still have the same problem i started with. I hope you can help me with some test procedures to pin point the problem.
Thank you.
Customer: replied 1 year ago.
Please let me know what you think.
Expert:  Kevin replied 1 year ago.

Sorry for delay .on the snap on machine you should be able to view live data for steering angle i would stary here and reset codes and view data whilst turning steering wheel to see if angle looks correct

Customer: replied 1 year ago.
Ok so what should it be? With the wheel straight forward should it be zero, and if turn it right or left what should the numbers change to?
Expert:  Kevin replied 1 year ago.

O is straigh ahead numbers should move gradually no hugh jumps one way positive the other negative .doesnt matter how high numbers go or which way just needs to be smooth and no hugh jumps