How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 23022
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now
A new question is answered every 9 seconds

Here's my issue, I had t a deer in my 2007 BMW M6 (E63/E64).

Customer Question

Hello Roger:
Here's my issue, I had hit a deer in my 2007 BMW M6 (E63/E64). I had to buy a new headlight assembly because it was cracked. I took the car to my local body shop to have them put the headlight in. It was a used headlight. When I took the car I for repair, even though the headlight was cracked, the lights were all still working fine. When I took the car home after the repair, the headlight on that side wasn't working. Just the beams weren't. Every other part is. The halos, the turn signal, and I believe there's even a small LED on it. They all still work except for the high and low beams. The bulbs are fine. I swapped bulbs from the passenger side too, just to be sure, and they wouldn't work either.
I know there's somethings called a ballast and an igniter. Would these be the issue, or could it be the module?
I have an OBDii cable and I have the Carly app for BMW and the fault says there's an unknown problem.
When I start the car, it show the "adaptive headligh
Submitted: 11 months ago.
Category: BMW
Expert:  Steve replied 11 months ago.
Hello and welcome,
My name is ***** ***** it will be my pleasure to assist you today
What beams? High and low
Customer: replied 11 months ago.
Yea. On the drivers side. Neither beam will work.
Customer: replied 11 months ago.
Do you have any ideas?
Expert:  Steve replied 11 months ago.
I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
the problem is most likely the ballast / control unit
I would swap them side to side, or better year, remove the entire working headlight, move it to the other side temporarily and hook it up to see if all works. If it still does not work, when the entire assembly is moved over, then you have a wiring issue.
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle
Expert:  Steve replied 11 months ago.
if there are no additional questions please kindly CLICK ON a positive rating
Expert:  Steve replied 11 months ago.
if there are no additional questions, as the question has been answered, please kindly CLICK ON a positive rating
Customer: replied 10 months ago.
I haven't had a chance to try the swap yet. When I do, I'll send you a message to let u know.
Expert:  Steve replied 10 months ago.
hi,
as the question has been answered, please kindly CLICK ON a positive rating to ensure I receive proper credit for my time and answer out of the deposit which you have already paid.
if you would like to follow up you are free to do so at any time with no additional charge after selecting a positive rating.
thank you in advance for CLICKING ON a positive rating