How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Roger Your Own Question
Roger
Roger, BMW Master Tech
Category: BMW
Satisfied Customers: 3037
Experience:  10 yrs. experience as BMW Master Technician, shop foreman and dealer.
8631066
Type Your BMW Question Here...
Roger is online now
A new question is answered every 9 seconds

Bmw running rough, blowing smoke misfiring

Customer Question

bmw running rough, blowing smoke misfiring
Submitted: 1 year ago.
Category: BMW
Expert:  Steve replied 1 year ago.
hello,
what question did you have about this?
Customer: replied 1 year ago.
hey,
Ive been trying to diagnose and repair this bmw and i am out of ideas on what could possibly be going on. it is running rough at idle misfiring, running very rich, ive done a good amount of work on it as far as eliminating possible causes and im still having the same issues. i was working with another mechanic briefly but he seems to have logged off and hasn't said anything about being back soon. i can send you the details of whats been done so far if you have the time to share some advice on what i should be trying next.
thanks, nick
Expert:  CHEVYEATER351 replied 1 year ago.

Hello my name is ***** ***** you add the list on this site for me to review please?

Customer: replied 1 year ago.
I ran a compression test which shows about 180lbs for each of the six cylinders, I did not run a vac test for the valves. fuel pressure is good and I believe the maf is good I haven't had a single code pop up from it yet. I do have a concern with the timing it starts at about six degrees adv and once its running it climbs all the way up to thirty. I can see fuel trims for bank 1 and 2.
This is the full run down of what ive checked and had happen/ change.
Started with car idling rough and blowing white smoke, smelled like oil and gas.
it was throwing the fallowing codes. P1353, P1132, P1620, P0174
started researching and decided the ccv is a fairly common part to fail so removed found small tear in diaphragm maybe 1/2 inch so replaced that. reassembled and had minor affects on how it ran, still shook and smoked like hell.
started looking more into cylinder six misfiring so i pulled spark plug found that valve cover gasket leaking into #6s( the one against the firewall if im right) spark plug well. pulled all plugs replaced valve cover gasket reassembled with new plugs started it.
It idled almost like normal but still blew a lot of smoke, smelling mostly like gas. after this it started throwing fuel injector 2&3 circuit low voltage codes, the large vac leak code didn't come back but it still sounded like it was gasping for air all the time.
At this time I started pulling codes more often and the battery started dying pretty often. it only dies if I leave the key in the on position and it doesn't take long to drain it maybe five minutes until its to dead to start. this doesn't seem right to me I don't feel like it should kill it that quickly. But back to the fuel injector codes I noticed that the fuel gage that was showing a little under a quarter tank was now showing almost empty and I hadn't run it that much just to test for changes so I ran some good fuel injector cleaner through it with a about five gallons of gas and it shut off the number two injector code three stayed on and I started getting misfire with fuel cut off on cylinders two and three as well as six occasionally. the next thing to change was the 02 sensor code randomly popped up and said no activity seen from o2 circuit. I realize now that I should not have overlooked the o2 and that this may be a big part of my problem. i didn't no to much about o2 sensors and i hadn't ran into an upstream o2 that had gone bad just downstream that didn't have much affect when they did go out. upstream are not like that. the hole time its been running extremely rich and now it seems like the battery drain is getting worse. its a lot to take in and im sure iv made more than a few mistakes but if you can help me narrow the issue down id greatly appreciate it.
Customer: replied 1 year ago.
sorry i no that doesn't make a hole lot of sense, its what i listed off to the first mechanic after he asked a few questions and wanted the rest of the details. basically the car is idling very rough and blowing out white smoke from the exhaust. its misfiring and running very rich and i cant seem to pin down the cause.
Expert:  CHEVYEATER351 replied 1 year ago.

Ok so this year has a M54 engine. You say that it smells like it is running rich? Try to connect a fuel pressure gauge to the fuel rail. Try to shut off the vehicle and then pinch off the pressure and return line of the fuel rail and make sure you do not have a injector/s leaking down. This will cause exactly what you are describing. Also what it the coolant temp reading this too will cause a rich issue if the temp is reading cold but within the spec. There is also an issue with lifters sticking on this engine when the get higher mileage, also could be a running issue. Are the front and rear O2 Sensors sweeping? If you have one stuck or the cats are blown out you will get weird codes and possible running issues. Let me know what you find.

Customer: replied 1 year ago.
alright, im not sure what the coolant temp is its been smoking so much that i wasn't to sure if i should run it long enough to let it warm up or not. what should it be at hot?
Expert:  CHEVYEATER351 replied 1 year ago.

The coolant temp would have to be read with a diagnostic reader and it should be around middle of the temp gauge and read about 190 degrees or so. Also is the oil level correct? The white smoke is oil so we need to make sure the oil is not over filled as well.

Customer: replied 1 year ago.
i have my laptop with an elm327 cable and some really basic software hooked to it so itll tell me coolant temp once i get it warmed up. the oil level is correct i have been checking it periodically sense i started. I really don't no where else the oil could be coming from if its not the ccv valve but i no nothing about these engines. the software gives me some live specs but not much ill test the o2 sensors for sweeping and the injectors tonight after i pick up a fuel pressure gauge but itll probably be pretty late by then, is it alright if i get back with you tomorrow morning to keep working on this?
Expert:  CHEVYEATER351 replied 1 year ago.

Yes not a problem. Talk to you then.

Customer: replied 1 year ago.
Cool, thanks. Talk to you tomorrow.
Expert:  CHEVYEATER351 replied 1 year ago.

I am just locking the question, just reply when you have time after the checks.

Related BMW Questions