How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: BMW
Satisfied Customers: 27126
Experience:  Over 17 years diagnosing and repairing vehicles.
14928985
Type Your BMW Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

1998 bmw wiper dont work wiper motor hums seconds then stops

Customer Question

1998 bmw wiper dont work wiper motor hums for 20 seconds then stops has voltage at motor plug pin 2 for 20 seconds then drops to 0
Submitted: 1 year ago.
Category: BMW
Customer: replied 1 year ago.
1998 bmw 528i
Expert:  peterpete190 replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

This can be due to poor wiring to the motor or poor ground to the wiper motor causing this here.I have seen both cause low amperage and cause this issue.The motor may have its proper power and ground signals but they may be weak signals due to damaged or corroded wiring or even loose connections causing this.I would inspect the wiring and see if any issues are found with it and if checked and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete.

Customer: replied 1 year ago.
Hi Pete, checked all the wiring and it all looks good. Do you happen to have any testing procedures that might eliminate some of the components? Like the motor,relay,switch,or GM.
Expert:  peterpete190 replied 1 year ago.

I apologize for the delay.Unfortunately I don't have a diagram or any testing procedure on this here myself but someone else here might have this info.I will open your question up for others here to see if anyone else can assist further on this.I hope you can get this resolved with ease.

Thanks Pete