How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask AZTechBrian Your Own Question
AZTechBrian
AZTechBrian, ASE Certified Technician
Category: BMW
Satisfied Customers: 704
Experience:  Owner
77606712
Type Your BMW Question Here...
AZTechBrian is online now
A new question is answered every 9 seconds

I'm having trouble seating the quick connector on the hose

Customer Question

I'm having trouble seating the quick connector on the hose running from the radiator to the thermostat. I can't seem to get the fitting to go on far enough.
any ideas what I might be doing wrong?
Submitted: 1 year ago.
Category: BMW
Expert:  AZTechBrian replied 1 year ago.

Is the rubber o ring catching up or has it come out of the groove?

Customer: replied 1 year ago.
No problem. I found the answer to my question on bimmerfest. The solution is to use a little silicone grease on both mating surfaces of the quick release hose coupling and the male thermostat fitting. Snapped in place easy as pie. Amazing what a little lube will do.
Expert:  AZTechBrian replied 1 year ago.

exactly. The rubber o ring is catching up.

Expert:  AZTechBrian replied 1 year ago.

Silicone is what I use as well.

Expert:  AZTechBrian replied 1 year ago.

LOL.. yes