How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Roger Your Own Question
Roger
Roger, BMW Master Tech
Category: BMW
Satisfied Customers: 3037
Experience:  10 yrs. experience as BMW Master Technician, shop foreman and dealer.
8631066
Type Your BMW Question Here...
Roger is online now
A new question is answered every 9 seconds

I have a 2011 Z4 35i manual (54k miles), that is exibiting

Customer Question

I have a 2011 Z4 35i manual (54k miles), that is exibiting an issue i've never seen in any of my cars before. I first noticed something wrong with the car because cruise control often won't engage, just displays dashes, or will engage briefly but then disables when the car puts it under load. Additionally the vehicle now has lost power end power, having to get it up considerably in RPM before producing decent power, and even then the revs don't seem to match what i feel happening in the car. I originally thought maybe it was a vanos issue, but now wonder if its not something clutch related. I plan to have it inspected soon, I am just traveling for work so it will be a couple weeks, and its driving me crazy not knowing. Any input or help when I take it in to listen for is greatly appreciated. Cheers!
Submitted: 1 year ago.
Category: BMW
Customer: replied 1 year ago.
Sorry that should say "lost low end power"
Expert:  Steve replied 1 year ago.
Hello and welcome,
My name is ***** ***** it will be my pleasure to assist you today.
What diagnostics have been carried out thus far?
Customer: replied 1 year ago.
All services up to date, no error codes or dashboard warnings.
Customer: replied 1 year ago.
Any ideas?

Related BMW Questions