How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 23690
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now
A new question is answered every 9 seconds

2007 bmw 328i replaced ballast and igniter/bulb unit and

Customer Question

2007 bmw 328i replaced ballast and igniter/bulb unit and passenger adaptive xenon low beam does not ignite scanner shows in footwell module data that it is powering up then drops off about 3 times then low beam malfunction on dash illuminates, what could it be?
Submitted: 1 year ago.
Category: BMW
Expert:  Steve replied 1 year ago.

hi, this would have to be a wiring short somewhere or a problem with the footwell module itself.

Expert:  Steve replied 1 year ago.

I would consider moving the headlight over to the other side and holding it in place to be 100% sure that the issue is not with the ballast or bulb. then start looking to the wiring.

Expert:  Steve replied 1 year ago.

Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.

Customer: replied 1 year ago.
moved to other side still does not work could it be high voltage cable or one of the other wires in it? I put another new bulb in it again to make sure that was not it and it has new ballast also
Expert:  Steve replied 1 year ago.

start with the high voltage cable

Expert:  Steve replied 1 year ago.

Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.

Customer: replied 1 year ago.
thank you i will try it but now i have to see if i can find a rotor assembly for an s500 central locking vaccum pump i will see if the other headlamp cable will allow the igniter to fire later this afternoon
Expert:  Steve replied 1 year ago.

ok good luck. please do not forget to CLICK ON a positive rating

Expert:  Steve replied 1 year ago.

if you would like to follow up after leaving a positive rating you are free to do so without additional charge after rating

Expert:  Steve replied 1 year ago.

Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.

Expert:  Steve replied 1 year ago.

are you having a technical problem selecting a positive rating?