How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Engineer
Category: BMW
Satisfied Customers: 21113
Experience:  Mechanical Engineer with 20 years experience in the auto industry, 8 yrs in formula 1 engine testing
12772297
Type Your BMW Question Here...
Matt is online now
A new question is answered every 9 seconds

Okay I am have some vanos low oil pressure issur on my 07 m6

Customer Question

Okay I am have some vanos low oil pressure issur on my 07 m6 coupe. First the car was running real bad and started tapping which was con rod bearings so I fix those knock is gone now. I replace high pressure line from vanos pump so it is not leaking I flush out and clean the whole engine of any possible shavings re-assemble and did a vanos pressure test am getting 1000psi or 75bars but am still getting a vanos oil pressure warning I also notice the car kinda run a little off and if I rev it up in neutral it will sometime shut off I also notice a power lose if I try to drive it but the car now run 95% compare to couple of weeks ago when I had 20 codes now I only have one after all the work is done to it and that's low vanos oil pressure. Could it be the solenoids or the vanos unit them selves? But the vanos units are not making any noise the car run so good but something is little off
Submitted: 1 year ago.
Category: BMW
Expert:  Matt replied 1 year ago.

Hello

if the car is running well with plenty of low down power and good fuel consumption then its likley that the VANOS system is operating correctly

I'd suggest its possible that 1 or more of the solenoids may be stcking, so producing a slow response and so the error message so that'd be the next items I'd flush out

Customer: replied 1 year ago.
Okay today I did a oil pressure test on both vanos units bank one only had 400psi bank 2 han1000psi I also get a low reading from bank 1 exhaust selonide
Expert:  Matt replied 1 year ago.

Hello

sounds like you might be gettting close

I'd replace that exhaust solenoid as the next step

Expert:  Matt replied 1 year ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. so if my answers have been helpful please rate my answer.