How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Engineer
Category: BMW
Satisfied Customers: 20602
Experience:  Mechanical Engineer with 20 years experience in the auto industry, 8 yrs in formula 1 engine testing
12772297
Type Your BMW Question Here...
Matt is online now
A new question is answered every 9 seconds

I'm trying to help my inlaw fix her 2006 BMW 330xi e90 with

Customer Question

Hello. I'm trying to help my inlaw fix her 2006 BMW 330xi e90 with around 88,000 miles. The car stalled while it was going about 30 mph. Good crank but no start. Replaced fuel pump and getting good voltage. So far I've had code: 2a9a 2a9b 2aa0 2aa1 2d5f 2a80. I've replaced both camshaft sensors, both vanos solenoids, and crankshaft position sensor. But now I still have code 2a9a. The car cranks but no start. Thank you for your time.
Submitted: 1 year ago.
Category: BMW
Expert:  Matt replied 1 year ago.

Hello

as you've already replaced the sensors I'd suggest checking over the condition of the engine wiring loom, especially where it passes over other parts and where it passes through the bulkhead

if this is OK then check that you have 12v on the ECU fuses and that the ECU relay is switching as it should

and if this is OK then I'd send the ECU off for testing at a place like this

http://www.ecudoctors.com/

http://stores.digitalautotech.com/StoreFront.bok

Expert:  Matt replied 1 year ago.

hi

do you stiill need help?