How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, ASE Certified Technician
Category: BMW
Satisfied Customers: 53156
Experience:  ASE & Bosch Certified Master Tech. Over 30 years experience.
13230946
Type Your BMW Question Here...
Marty is online now
A new question is answered every 9 seconds

525i: 94 525i no spark, no fuel pump

Customer Question

94 525i no spark, no fuel pump
Submitted: 1 year ago.
Category: BMW
Expert:  Steve replied 1 year ago.
hi.
I am not sure how to interpret "94 525i no spark, no fuel pump "
what is your question?
Customer: replied 1 year ago.
Crank no start 1994 BMW 525i. Fuel pump does not turn on and has no spark
Expert:  Steve replied 1 year ago.
do you want to know possible causes? something else?
Customer: replied 1 year ago.
Yes causes
Expert:  Steve replied 1 year ago.
what has been checked / replaced so far?
Customer: replied 1 year ago.
Fuel pump works, just not receiving voltage, no spark. Checked fuses under hood
Expert:  Steve replied 1 year ago.
I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
the most common causes would be:
failed crank sensor
failed ECU (called a DME on a BMW)
problem with ECU power supply (DME main relay)
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.
Customer: replied 1 year ago.
And replaced crank position sensor
Expert:  Steve replied 1 year ago.
I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
the most common causes would be:
failed crank sensor (if you replaced this then it is not the issue)
failed ECU (called a DME on a BMW)
problem with ECU power supply (DME main relay)
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle.
Customer: replied 1 year ago.
Replaced ecu today with a known good one, sorry forgot that, do you know where the main relay is
Expert:  Steve replied 1 year ago.
hi,
I asked what had been done
you said just fuses.
now you say crank sensor and dme...
what else has been replaced?
Customer: replied 1 year ago.
Calm down there slick.Ecu, cps, and fuel pump are good.
Expert:  Steve replied 1 year ago.
I am sorry but it is extremely difficult to provide an answer when I am provided with incorrect information.
I have made an offer.
Customer: replied 1 year ago.
Lol I gave you the info like 10 times, you sound like you have never worked on a car in your life. I just want other possible wiring or sensor issues that cause no fuel pump and no spark on a 94 BMW 525i
Expert:  Steve replied 1 year ago.
I am going to opt out of your question.
Customer: replied 1 year ago.
Opting out cause you don't know the answer, smart play
Expert:  Marty replied 1 year ago.
Hi, perhaps I can help. My name is***** relays are located in the E-box at the right rear of the engine compartment. I'd either replace the main relay and the fuel pump relay or do some voltage checks to the ECU to see if it's getting power. Copy and paste the link below for the relay locations. Let me know if you need further assistance.
http://www.mediafire.com/view/zsdoqaamkj726cl/relays.pdf
Customer: replied 1 year ago.
Thanks Marty you are helpful I'll let you know in a second
Expert:  Marty replied 1 year ago.
Glad to help. I'll be leaving work in a few minutes to drive home. I'll be back online later tonight if you need anything.
Marty
Customer: replied 1 year ago.
So I checked the main relay and fuel pump relay and they both work, the main relay powers up but the FP relay isn't receiving signal from the DME so it doesn't turn on, but if I just the relay the fuel pump comes right on
Customer: replied 1 year ago.
Jump**
Expert:  Marty replied 1 year ago.
Hi, try jumping power directly to the DME or to the output of the main relay to the DME . I want to make sure that the DME is getting a good 12V. If you have a fault with the power supply to the main relay it can cause the problem. Also check to see if the fuel pump runs for half a second when you cycle the key on and off. Also make sure terminal 26 at the DME has battery voltage.