How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, BMW Expert
Category: BMW
Satisfied Customers: 23019
Experience:  BMW Expert
26942375
Type Your BMW Question Here...
Steve is online now
A new question is answered every 9 seconds

Z3 Roadster: 96 z3 changed plugs and filter disconnected battery.

Customer Question

96 z3 changed plugs and filter disconnected battery. once work done re-connected battery started car and don't have speedo or tach. Tried running check thru trip meter switch and it won't cycle, just has 4 or 5 lit squares but no movement to diagnostic cycle. This is with engine off and ignition on. Any suggestions
Submitted: 1 year ago.
Category: BMW
Expert:  Steve replied 1 year ago.
hello
I will provide an honest answer. I trust this will be appreciated. Please remember that a low rating PUNISHES me for being honest and that I receive nothing for my time until a positive rating is clicked.
Please check your fuses if you have not. should be 23 27 31 and 46 but verify on your own fuse diagram
if there are no blown fuses, then unfortunately this indicates a failure of the cluster itself as the tach and speedo info come from different systems and have only the cluster in common.
you can possibly send it out for repair, contact module masters or programma inc to see if they can help
Please let me know if you have further questions. Please do not forget to click a positive rating as this is the only way I receive credit for my answer, thank you. Best wishes with your vehicle

Related BMW Questions