How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Webb-Guy Your Own Question
Webb-Guy
Webb-Guy, Home Appliance Technician
Category: Australia Whitegoods
Satisfied Customers: 1424
Experience:  maitenance tech at casto
95800582
Type Your Australia Whitegoods Question Here...
Webb-Guy is online now
A new question is answered every 9 seconds

We have a Kelvinator ksm 6100 wf. We had a power failure and

Customer Question

Hi we have a Kelvinator ksm 6100 wf. We had a power failure and when the power came back on it froze everything in the fridge. We turned it off., then turned it on the next day and was ok for a few days then the the fridge got hot. The freezer side was still working. Just wondering what it could be. Ta David
JA: Have you tried power cycling the appliance -- unplugging it and leaving it off for a few hours?
Customer: Did that turned it back on the other night, I think it ran all night I heard it every time I woke up.
JA: Do you plan on doing the work yourself?
Customer: If it something simple as changing a curciut board
JA: Anything else we should know to help you best?
Customer: Location of curcit board, at least I could see if it has damage
Submitted: 5 months ago.
Category: Australia Whitegoods
Expert:  Webb-Guy replied 5 months ago.

Hello and welcome to just answer my name is ***** ***** I will be the one to assist you. Give me just a moment to pull up some information for you and i will be right with you.

Expert:  Webb-Guy replied 5 months ago.

Have you inspected to see if the two fans in your unit are both running? How about the compressor is it running. I assume it is since the freezer is remaining cold but has been running constantly. It sounds like its more of a thermistor issue than a board issue since the freezer is still working. Typically the boards are located right underneath of these units or in the back on the freezer lower hand side.