How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kelly Your Own Question
Kelly
Kelly, Appliance Technician
Category: Australia Whitegoods
Satisfied Customers: 19055
Experience:  Highly accurate diagnostician with over 30 years of experience.
11418111
Type Your Australia Whitegoods Question Here...
Kelly is online now
A new question is answered every 9 seconds

I have a Fisher and Paykel MW512 washing machine which

Customer Question

I have a Fisher and Paykel MW512 washing machine which started acting up recently. Spin cycle too slow and the hot and cold lights flight together. I figured out that it had something to do with the inlet hose pipes and screen being blocked. When I disconnected the hose pipes from the water inlet to clean them up I found what appeared to be crushed plastic blue pieces of a washer. However I can see a black rubber washer inside the hose pipe, on the side which connects to the water inlet.
After i cleaned up the mess and re-connected them. The hose pipes started leaking. My machine went on to do a proper wash cycle without any errors, but lots of water on the ground. Do I need to replace the hose pipes?
Submitted: 4 months ago.
Category: Australia Whitegoods
Expert:  Kelly replied 4 months ago.

Hi, welcome to Just Answer. My name is ***** ***** I look forward to helping you!

Please know that I am not compensated for my time by the site until you rate using the stars at the top of your page. A rating is appreciated once we get to the solution for your appliance issue, thanks!

The inlet hoses and the water inlet valve should all be replaced. It is always best to err on the side of caution when water is involved!

Customer: replied 4 months ago.
Hi Kelly. thanks for your time but it appears I wasn't screwing the hose pipes properly onto the machine. once fixed they havnt leaked and I have tested with 2 washes now. also I checked specifications for all fisher paykel inlet hose pipes and it appears none of them have any blue washers or anything. we had a problem with our water lines a few days ago and it seems some garbage may have flown into the pipes via the water inlets. I have since cleaned hose pipers and their screens and secured them to the washer properly and the machine is as good as new. thanks for your time but I suppose I was able to fix my problem.

Related Australia Whitegoods Questions