How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randy 43 Your Own Question
Randy 43
Randy 43, Home Appliance Technician
Category: Australia Whitegoods
Satisfied Customers: 3764
Experience:  20 yrs experience 18 in home,gas license , refrigeration expert
13202342
Type Your Australia Whitegoods Question Here...
Randy 43 is online now
A new question is answered every 9 seconds

I have a westinghouse oven model wfe946sa. The oven is not

Customer Question

Hi I have a westinghouse oven model wfe946sa. The oven is not heating up at all. The lights are on in the oven ect but not heating. Tried turning oven off at wall and restarting it but still nothing
JA: I'll do all I can to help. Tell me a bit more about what's going on so we can help you best.
Customer: Everything else is working including cooktop but oven not heating up
JA: Is there anything else the Whitegoods Technician should be aware of?
Customer: NO
JA: I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Whitegoods Technician about your situation and connect you two.
Submitted: 1 year ago.
Category: Australia Whitegoods
Expert:  Randy 43 replied 1 year ago.

hello ,do the top burners work ?and is it both bake and broil not working in the oven?thx Randy

Customer: replied 1 year ago.
Hi Randy, yes the top element's work and no bake or grill in oven. Oven light and fan work though.
Expert:  Randy 43 replied 1 year ago.

if the top burners work that means the power coming to the range is fine ,they both use 220volts ..if both bake and broil do not work ,its not likely both elements went out at the same time ..its most likely going to be the main control board ,the main relay on that board is gone ,or the wiring to that board relay is shorted or bad,if you remove the rear panel and look for any obvious shorts or bad connections to that board ,if all ok ?i would suspect the board , if you have a meter you can ohm out the elements and the high limit thermostat, if this occured after a self clean? elements and hi limit should all show continuity

Expert:  Randy 43 replied 1 year ago.

Thermal Fuse

RepairClinic Item # *****

Watch Video:

Skill Level: Skill Level

Thermal fuse

OEM Part - Manufacturer #3196548

$14.05

Quantity:

In Stock

ADD TO CART

36

check this thermal fuse for continuity

Expert:  Randy 43 replied 1 year ago.

my other post got deleted ,sorry

Expert:  Randy 43 replied 1 year ago.

if all else test ok ,power is good ,and no bad wiring to the board,then the main board would be faulty ,they share the line relay on the board

Expert:  Randy 43 replied 1 year ago.

elements wont both go bad at the same time ,and the top burners working verifies that power to range is good

Customer: replied 1 year ago.
Ok thank you. Will check out tomorrow morning. Thanks for your help. ☺
Expert:  Randy 43 replied 1 year ago.

ok good luck