How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Appliance Guru Your Own Question
Appliance Guru
Appliance Guru, Owner and Technician
Category: Australia Whitegoods
Satisfied Customers: 13996
Experience:  Over 15 yrs. experience with 10,000+ in home repairs.
21107370
Type Your Australia Whitegoods Question Here...
Appliance Guru is online now
A new question is answered every 9 seconds

We have a Westinghouse Double Oven Model 792 and the display

Customer Question

We have a Westinghouse Double Oven Model 792 and the display is showing a meat probe symbol and this is preventing the top oven from working. No probe has been used recently (in fact we don't have one) and has only just appeared. Is there a way to reset?
JA: Thanks. Can you give me any more details about your issue?
Customer: Such as?
JA: OK got it. Last thing — AU Appliance Technicians generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 9 months ago.
Category: Australia Whitegoods
Expert:  Jamie_2013 replied 9 months ago.

Please post complete model number.

Customer: replied 9 months ago.
The oven is at a different location and will need to access this on Wednesday and provide
Expert:  Jamie_2013 replied 9 months ago.

okay, not a problem.

Customer: replied 9 months ago.
ok the model number is ***** and the product reference in need is(###) ###-####
Expert:  Appliance Guru replied 9 months ago.

Hello and thanks for using this service, I am APPLIANCE GURU if you have been waiting do not worry or get upset I am just one of the techs on here and I try to get to as many customers as I can and I just picked up your question now. Please allow time for me to respond, sometimes I get the questions or responses late so please be patient as I have no control over the site issues. NOTE, I have nothing to do with your payment to the site and did not receive that money. You have to supply a rating in order for us techs to receive credit for our time as we have nothing to do with any payment made to the site.

Do you have the meat probe still?

Customer: replied 9 months ago.
I had responded to the initial technician that had replied seeking the model number which is now provided. We have not received a response with a suggested resolution yet
Expert:  Appliance Guru replied 9 months ago.

I understand and sorry for the first techs response. You need to get the probe for the unit and often it just takes inserting it and removing it a couple times to get that to clear. Can you do that?

Customer: replied 9 months ago.
Unfortunately we have never had a probe so don't have that option. Not sure what caused it to occur in the first place
Expert:  Appliance Guru replied 9 months ago.

The socket sometimes corrodes or the little tin piece touches and causes the board to think the probe has been inserted into the socket. Often you can turn power off to the unit...Spray a very very small amount of WD-40 in the socket and turn the power back on and try it most times it will clear the code. Let me know.

I would like you to know that I am a tech that works for the site, the payment you made to the site is not automatically credited to me nor do I receive all of the payment you made. The only way I receive any credit at all for my time is by you selecting a STAR using the 5 STAR RATING SYSTEM on your page before you leave. If you are not happy with the service please let me know before leaving a negative rating. This will also allow you to get directly back to me for FREE follow up questions and tips are greatly appreciated! Thanks

Customer: replied 9 months ago.
Thank you we have tried to turn the power off without luck previously but not he WD40. We will try this next week when we are back at the house and advise.
Expert:  Appliance Guru replied 9 months ago.

OK sounds good

Related Australia Whitegoods Questions