How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis Your Own Question
Curtis
Curtis, Australia Car Mechanic
Category: Australia Car
Satisfied Customers: 1606
Experience:  Qualified Automotive Mechanic, LPG & Airconditioning Diagnostic Technician.
29271542
Type Your Australia Car Question Here...
Curtis is online now
A new question is answered every 9 seconds

I'm in Australia ,I recently purchased a 2006 PT Cruiser

Customer Question

Hello I'm in Australia ,I recently purchased a 2006 PT Cruiser with stop lights not working both left and right but upper on trunk lid works fine.
JA: Have you tried silicone spray or WD-40?
Customer: wd 40 on what?
JA: Are you fixing your PT Cruiser yourself? What have you tried so far?
Customer: I'm trying to fix it myself. it also appears to have no power to the trailer hitch.
JA: Anything else you want the mechanic to know before I connect you?
Customer: If I supply an external 12 volts to either lower stop lights they both come on. thanks Mario
Submitted: 4 months ago.
Category: Australia Car
Expert:  david craig replied 4 months ago.

Hi Im David what engine do you have in the cruiser?

Customer: replied 4 months ago.
2.4ltr non turbo
Expert:  david craig replied 4 months ago.

Have you checked the fuses in the tipm?

Customer: replied 4 months ago.
The brake fuse is ok,checked with multimeter
Customer: replied 4 months ago.
The third light on hatch cover comes on when you apply brakes
Expert:  david craig replied 4 months ago.

totally different circuit for the third brake light

Expert:  david craig replied 4 months ago.

pull the fuse, check for power on one side.

Customer: replied 4 months ago.
way past my bed time can we continue in the morning. Are you in australia THANKS
Expert:  david craig replied 4 months ago.

in the states its 7:46 am

Customer: replied 4 months ago.
Checking with meter can't find any power on factory fitted trailer socket either no turn indicator or park lights.
Expert:  david craig replied 4 months ago.

need to focus on brake lights first. check for power at fuse for brakes.

Expert:  david craig replied 4 months ago.

ill be back on tonight. go get some sleep

Customer: replied 4 months ago.
Thank you ......Mario
Expert:  david craig replied 4 months ago.

you bet

Expert:  david craig replied 4 months ago.

any update?

Expert:  david craig replied 4 months ago.

do you still need assistance?

Customer: replied 4 months ago.
Sorry David for the delay in response, this car Imay regret ever buying,the battery went flat after talking with you have had the charger on it .Checked all fuses and have power on both sides,the only brake fuse I see is marked CHML and that's ok but now the car has developed another fault the starter won't engage I'll have to ckeck if there's power to the starter solenoid when I turn the key .I purchased the car as a non runner with a broken timing belt that has been replaced complete with tensioner idler and water pump.previously the car hadbeen sitting faulty since April
Expert:  david craig replied 4 months ago.

ok, sounds like we got some work to do.

Expert:  david craig replied 4 months ago.

the fuse chml is for the 3rd brake light which as i have said is on a separate circuit than the others. let me pull up a print for you.

Customer: replied 4 months ago.
The engine started and ran beautifully after the timing belt replacement
Expert:  david craig replied 4 months ago.

ok. well we can check for power to the starter to start with, but im hoping this is a problem with the tipm... still looking for power for the brake lights. thanks for your patience

Expert:  david craig replied 4 months ago.

The main brake lamps aren't on a fused circuit. These are controlled by the TIPM, the module/fuse box under the hood. If both of them have quit working at the same time but not the third brake lamp then you know it's not a fuse. The brake lamp switch gets a fused battery voltage feed from fuse 3 under the hood, but that is also used for the third brake lamp and all other outputs

Expert:  david craig replied 4 months ago.

The first thing I would recommend is disconnecting the battery. This will clear any fault codes stored in the TIPM and may restore operation. If not then you may have a bad brake switch

Customer: replied 4 months ago.
Thanks David ,it's after midnight here,I'll check in the morning. Sorry to bother you. Good night.
Expert:  david craig replied 4 months ago.

sounds good. and you're not bothering me. its 9am here. just starting my day.