How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Australia Car
Satisfied Customers: 21413
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
Type Your Australia Car Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

My2005 wrangler 4.0 litre efi has no power getting to ign

Customer Question

my2005 wrangler 4.0 litre efi has no power getting to ign coil.
Submitted: 17 days ago.
Category: Australia Car
Expert:  sprinkles08 replied 16 days ago.

Hello and welcome to JustAnswer!

If ASD circuit wiring was involved in the damage and the circuit shorted to ground then it would have blown the fuse. It's possible that a blown fuse was just overlooked.

The coil and injectors will only have power for about two seconds when the key is first turned on and then again while cranking as long as the cam and crank signals are present and in sync. Did you check for power briefly while turning the key on?

Customer: replied 4 days ago.
sprinkles 08
re jeep wrangler 2007 4 litre
thank you for enlightening me on the short power up time to coil &injectors after ignition switch on.
yes there is power at both and fuses are all ok,and there is fuel pressure at injector rail.
having now read of many people with the same problem I guess the camshaft and crank sensors are suspect.
kind regards neil.
ps is cam sensor in distributer shaft?
Expert:  sprinkles08 replied 3 days ago.
Can you post the VIN?

Related Australia Car Questions