How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, Australia Car Mechanic
Category: Australia Car
Satisfied Customers: 740
Experience:  Senior Technician
84449473
Type Your Australia Car Question Here...
Gary is online now
A new question is answered every 9 seconds

I've got a 97 wrx was auto now manual and it's been running

Customer Question

Hi. I've got a 97 wrx was auto now manual and it's been running crap wont hit boost keeps backfiring checked and fixed vac leak but problem never fixed so I've got a computer out of a 97 manual wrx and ran into the imoblizer issue so i now installed the correct ignation ballels that were on the car the computer came from so why wont my car start at all now not even if i try putting my old computer back in it. Please help
Submitted: 3 months ago.
Category: Australia Car
Expert:  Dan replied 3 months ago.

Hello my name is***** am an ASE Master Technician and I am glad to help you out with your question.

Expert:  Dan replied 3 months ago.

It may have lost the key registration, you could call a mobile locksmith to program the keys to the new computer if they have the correct software.

Customer: replied 3 months ago.
Ok so was there anything i should have done or a certian way i should have installed the new computer im really confused and im female which confuses the situation further.
Any thoughts on why loss of power n boost
Expert:  Dan replied 3 months ago.

Do you have any engine trouble codes?

Customer: replied 3 months ago.
my old computer doesn't work in the car now
Customer: replied 3 months ago.
No none
Expert:  Dan replied 3 months ago.

Disconnect both battery cables (positive and negative) and hold them together for 15 minutes. Then reconnect one at a time, positive first then negative. This should reset the system.

Customer: replied 3 months ago.
Already reset ecu previously hence the new computer as it would drop injection and only run on 3 cylinders just lost as to why i cant even get the car to start now
Customer: replied 3 months ago.
I have bypassed the impobilizer issue but now no fuel pressure sounds like faulty plugs ive spend thousands n thousands on this car
Customer: replied 3 months ago.
I have a brand new haltech elite 1500 with wiring loom and fuse box all brand new how much would it cost to install and tune it and could you send me somewhere in the sydney area please?
Expert:  Dan replied 3 months ago.

I am in the US I will opt out and another expert will help shortly

Customer: replied 3 months ago.
Thank you
Expert:  Gary replied 3 months ago.

Hi Jes,

The best I know in Sydney that have tuned one of my cars (02 Evo 5 Wrx) is:

http://www.autotechengineering.com.au/

They should be able to do the fitup and tune of your Haltech system.

Give them a call.

Gary