How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 24697
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

B170 press key button but no lock or open. Seems power is

Customer Question

Hi
JA: Hi. How can we help?
Customer: B170 press key button but no lock or open. Seems power is dead or something.
JA: Any trouble turning the key in the ignition? Do you have a key fob?
Customer: Inside car and can't turn key. As if it is locked
JA: What year is your B150?
Customer: Yes keyfob
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: B170 year 2008
JA: Anything else you think the mechanic should know?
Customer: Should be all. Maybe anti theft or something. No power I think
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mercedes Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Australia Car
Expert:  Pete replied 5 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

This sounds like a loss of power causing this fault here and may be caused by an issue with a loose or corroded or even damaged battery cable needing cleaned and tightened or replaced.I would check the power and ground feeds from the battery as well as the power feeds at the starter,alternator and fuse panels for any issues.If any issues are found they will need to be repaired to correct this fault here.If these are checked and found to be o.k. let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Australia Car Questions