How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 24692
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Mate i have a issue with a fault code showing no air sensor

Customer Question

Hi mate i have a issue with a fault code showing no air sensor measurement. But from reading your explaination to another fellow the vito(###) ###-####dosnt have a MFA if its not next to the airbox. Also i have a zero measurement reading on the injectors. And this is where my fault is i cannot release the amount of fuel through the return lines without it blowing the hoses.
Replaced fuel filter and plastic valve ontop of filter. Also the pressure regulator and injector pump. I got my mileage back up to where its suppose to be but experiencing lack of power and leakage through return lines.
Submitted: 7 months ago.
Category: Australia Car
Customer: replied 7 months ago.
I heard a Pop a month ago under bonnet or good when i started the van immediately. Since then power was dropped barely able to keep speed up a hill. I had an injector reseated and since then the return lines keep popping off. The van starts and runs fine no miss timing but i recon the fuel to aix mixture isnt correct. Vito 2002 112 cdi 638 engine with no MAF
Customer: replied 7 months ago.
Has never gone into limp mode, nothing comes up on dash. t revs fine all the way to redline. I do not have quick response though it feathers up on acceleration.... on flat road i can go top speed no prob. When i start the van it runs for about 6 seconds then you can hear a distinct pitch or tone drop slightly from the engine.
Expert:  Pete replied 7 months ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know. If you have not had the fuel injectors tested individually to see if one or more fuel injectors are at fault this should be done.If one or more are found to be at fault the affected injectors will need replaced to correct this issue here.I have seen several faulty injectors in the past cause issues like this here needing replaced.If these were already tested and found o.k. let me know. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete

Related Australia Car Questions