How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask indy-tech Your Own Question
indy-tech
indy-tech, Australia Car Mechanic
Category: Australia Car
Satisfied Customers: 7019
Experience:  All import and domestic car repairs and diagnostics
29331485
Type Your Australia Car Question Here...
indy-tech is online now
A new question is answered every 9 seconds

My 1997 mod BMW 535i has 165,000 km's on the clock and has

Customer Question

My 1997 mod BMW 535i has 165,000 km's on the clock and has developed a transmission
problem , the instruments tells me its in the " TRANS FAILSAFE PROG " . The car seems to be in the limp home mod but when you first start off when its cold , its back to normal for about 30 seconds then goes to failsafe mod . Is it low on oil or something electronic ? Greg.
Submitted: 1 year ago.
Category: Australia Car
Expert:  indy-tech replied 1 year ago.
Hi, I'm Greg (Indy-Tech). Welcome to JustAnswer. I'm reviewing your question now, and will post back with your reply ASAP. Any other warning lights on like check engine light on when the engine is running .Rgds Greg.
Customer: replied 1 year ago.
The ABS light was on also the ASC+T but they are not on now, just the Trans Failsafe Prog.
Expert:  indy-tech replied 1 year ago.
Okay good thank you. Your transmission management system needs to be hooked up to a diagnostic scan tool to check for transmission malfunction codes . When the ABS and ASC light also trip on then in most cases you will find you have just a possible input or output speed sensor .But you need to hook up and check for codes to be sure that this is the problem, as other sensors could also cause this issue .. Still need additional information then please get back to me with the reply button, and not the poor or bad service, this way i can get back to you or suggest another expert if needed. Your deposit does not pay me until the answer is rated in a positive way,A bad rating does not constitute a refund.If you are not happy or you have sorted out your problem before the answer then please let me know with the reply button .Kind regards Greg.
Customer: replied 1 year ago.
I took the car to a local mechanic and he plugged a "snap on" diagnostic gadget to it and came up with 106 stall monitor . If that makes any sense to you . Greg.
Customer: replied 1 year ago.
I'm going to take the car to another mechanic tomorrow and put it on the hoist to check oil levels and anything else we can find , I will let you know how we get on. Greg.
Expert:  indy-tech replied 1 year ago.
Okay sounds good. But see if you can find a shop that works on BMW and has the BMW diagnostic tool to check for codes .I find the snappy are very limited on EU cars . Rgds Greg
Expert:  indy-tech replied 1 year ago.
Hi GregAccording to my data the 106 is your Output speed sensor ?Just as i speculated .. Have this checked with a BMW diagnostic scan tool . Rgds Greg

Related Australia Car Questions