How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 26726
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

My name is ***** ***** I have a range rover sport 2010 v8 i

Customer Question

My name is ***** *****
JA: Thanks. Can you give me any more details about your issue?
Customer: I have a range rover sport 2010 v8 i have been getting an error on the screen 'stability control - not availalbe drive with care' The car then restrict speed performance It seems to happen when i am travelling at about 70/80kmh Always on an open road and the gears drop down to 4th or 5th And the idle seems lower I have to then pull over, turn it off and restart and it goes away till the next time i seem to go this speed, this idle again Ever heard of this ?
JA: OK got it. Last thing — Auto Mechanics generally expect a deposit of about $24 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Australia Car
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Most likely one of the suspension or brake sensors are sending an incorrect signal at higher speeds causing the message and issue you see here.What has to be done from here unfortunately is to have a scan tool/computer plugged into your model to read what codes are set.Once this is done any codes set need to be diagnosed to locate and repair this issue here.This has to be done because there is a large number of different components that can fail/act up and cause this here and this will help pinpoint the cause for repair.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete