How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Australia Car
Satisfied Customers: 21413
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
Type Your Australia Car Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

My 08 ace van is stuck in first gear. The engine light is on

Customer Question

my 08 hiace van is stuck in first gear . The engine light is on and when i turn the headlights on the R for reverse light comes on
JA: It's good that it's giving you information about the problem. The Toyota Mechanic will know what to do. Tell me a bit more about what's going on so he can help you best.
Customer: every thing else is fine but it won't change into second. how do i reset the computer?
JA: Are you hoping to fix this yourself?
Customer: i hope so
JA: Is there anything else the Toyota Mechanic should be aware of about your Toyota?
Customer: no
JA: I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Toyota Mechanic about your situation and connect you two.
Submitted: 7 months ago.
Category: Australia Car
Expert:  sprinkles08 replied 7 months ago.

Hello and welcome to JustAnswer!

The reverse indicator is likely coming on due to a ground issue with the rear lighting, the park lamps are most likely finding ground through the transmission range sensor.

The trans isn't shifting and the engine light is on because the trans controller has identified an issue that will prevent proper operation and a fault code has set. There are many possible causes for limp in ranging from speed sensors, solenoids, wiring, internal trans issues, the TCM, or t may be related to the indicator issue you're experiencing.

The first step in diagnosing the problem will be to use a scan tool or code reader to see what fault codes are setting in the trans controller and then testing will need to be done from there based on what is set.

Related Australia Car Questions