How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 26371
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

2005 ba had steering lock repaired and now horn/alarm goes

Customer Question

2005 ba had steering lock repaired and now horn/alarm goes when i connect the battery.
JA: Thanks. Can you give me any more details about your issue?
Customer: if remove the relay-horn car starts etc but said security code error
JA: OK got it. Last thing — AU Auto Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Australia Car
Customer: replied 1 year ago.
car runs ok and radio works etc door lock etc. all with relay removed. no error code on screen but cant fit the relay without horn alarm going off
Customer: replied 1 year ago.
i disconnected the battery. refit relay and reconnect battery,horn goes off.over 30 seconds still going.disconnected battery and remove relay again.reconnected and start up car.security code error came up dash until started.
car runs .radio works .car unlocks and locks from remote. turned off car and restarted no message.but no horn relay fitted,
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

If your model has the metal key blade and metal key cylinder on the doors or trunk try locking and unlocking the vehicle with the key blade and then try and start the vehicle and see if the alarm then goes off.If it does not this may have reset the locks to correct this here.If the fault still occurs let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 1 year ago.
car does not have boot barrel -key only on remote.key is long pin.i have tried locking with this all doors and boot lock and unlock.but alarm horn still going off. car is 2005 xr8 boss 260, 4 door with factory alarm .i disconnected battery before work
i removed steering column to get ignition lock repaired as the spring wouldnt return key back.after starting,
i remove column and send to locksmith.after 10 day got back and fitted.i removed remote attached by key on the outside off column.1 screw holds this on..could some think be wrong inside lock?.steering shaft only fit one way.
Expert:  Pete replied 1 year ago.

I would start with having the area checked where the work was done for the steering lock here.If there is any damaged wiring or disconnected components in this area this can cause this type of fault here.I have seen this before where a sensor is damaged or unplugged or wiring damaged at the column when this repair is done needing repaired to correct this fault here.If this has already been checked and found to be o.k. let me know so we can continue.

Thanks Pete

Customer: replied 1 year ago.
ok found the fault,the undid the lh screw 1/2 turn hold the air bag in.and horn stopped.
i must have done the screw to tight.,undid and remove air bag and check wires all look ok
refitted and with horn plug disconnected in steering wheel and ok.refitted plug and horn stuck on again.
loosened off screw 1/4-1/2 turn and problem gone.
Expert:  Pete replied 1 year ago.

That is great to hear the fault has been located.Most likely the screw was grounding out the signal when in to tight causing this issue here or the screw is to long and needs replaced with a shorter one.

Let me know if you need anything else and feel free to rate my help here.

Thanks Pete

Related Australia Car Questions