How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 24721
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a Toyota, not sure what year or model but it would be

Customer Question

I have a Toyota, not sure what year or model but it would be in the 1980 era. The problem is that it will start but the revs have to be kept up to keep it running and there is no power to the lights, indicators or dash board gauges. it is an electrical problem and I have checked every thing in the cabling. sometimes it will correct itself and run properly but the problem recurs. Regulator ? your information would be much appreciated Thanks ***********
Submitted: 11 months ago.
Category: Australia Car
Expert:  Pete replied 11 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Check and make sure the main battery cables are clean and tight at the battery itself and where the cables lead to from the battery.I have seen issues with these cables that can cause this issue here before requiring replacement to correct this issue here.If this is or was checked and found o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 months ago.
Hi. the battery is new and connections OK. The motor cranks over fast and I was wondering if it may be the voltage regulator as the electrical circuit is incomplete. as I said the motor runs but needs revs to keep it going and lights etc. are not working.Before starting the ignition switch when turned on the dashboard lights would show and everything else would work but now they do not work, and this seems to upset the motor at low revs. Cheers. Bruce
Customer: replied 11 months ago.
Another thought could it be the ignition switch ? thanks for your help
Customer: replied 11 months ago.
no more information at this stage
Expert:  Pete replied 11 months ago.

I apologize for the delay as I was off line when you had posted the last few times last night.

I am leaning towards a possible electrical failure in the electronic ignition switch itself.I have seen the ignition switch fail before in the past needing replaced to correct this type of fault here.This will have to be tested further with the correct diagrams and correct test equipment to be sure this is the cause here but this does sound like the electronic ignition switch itself is at fault needing replaced.

Thanks Pete