How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis Your Own Question
Curtis
Curtis, Australia Car Mechanic
Category: Australia Car
Satisfied Customers: 1606
Experience:  Qualified Automotive Mechanic, LPG & Airconditioning Diagnostic Technician.
29271542
Type Your Australia Car Question Here...
Curtis is online now
A new question is answered every 9 seconds

I have 2005 vw transporter 2 litre petrol manual, start fine

Customer Question

I have 2005 vw transporter 2 litre petrol manual, start fine when cold, as the temp come up say around 1/4 up the temp guage its starts to idle fast around 1200 rpm, when it gets to 1/3 on the guage it idles around 2300 rpm, turn the ac on it drops back to 900 rpm, after it get to full operating temp it start to hunt, revving up & down, I have replaced the throttle body & the air flow meter & 02 sensor 1, the original codes were, 16891 idle control system higher than expected, p0607 upper limit reached, 17950 angle sensor throttle motor g187 not a plausible, p1542 not a plausible intermittent, can you help with any imformation please, Eric
Submitted: 1 year ago.
Category: Australia Car
Expert:  Wolfgang replied 1 year ago.

Thanks for choosing Just Answer . I'm Wolfgang here to help!!
Below is my first answer or request for more information. If you do not understand it, or you need more information from me, or need me to go in more detail. Do not rate yet, just reply. Put yourself in my shoes, I can not see, smell, hear, feel or touch your car, nor do I know any history on it. So take into consideration I am doing my best based on what you tell me. Also understand fixing cars often requires sophisticated tools, that you may not own. So even if you can not do what is outlined in my answer, that does not mean my answer is wrong deserving to be rated negative.

what codes are stored now after the parts replacement please?

thanks

Customer: replied 1 year ago.
Hi Wolfgang,at this stage no codes, no vacuum leaks, was tested with a smoke machine, the car drives fine only when you drive it , when you pull up at the lights it want to idle around 2200 rpm, the car is back with owner, will be back on Monday. I will re scan then & let you know, thanks
Expert:  Wolfgang replied 1 year ago.

THAT IS A GAME PLAN!!

Customer: replied 1 year ago.
Hi Wolfgang still have no codes logged, the only problem we have is as the temp comes up to operating temp the motor wants to idle up to 2200rpm, the owner said it runs fine, no missing or surging whilst driving.
Expert:  Wolfgang replied 1 year ago.

please check ecm grounds make sure they are clean and tight. i have see this where a not a good ground can cause this!!! usually they are located on the frame rail and near the ecu but for good measure check all grounds. let me know if you still need help

Related Australia Car Questions