How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 26621
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Started with with van randomly losing power (like having a

Customer Question

started with with van randomly losing power (like having a blown turbo) its some kind of limp mode. can be reset 2 or 3 times by switching off engine (trans in park) and re starting. No engine light. Sometimes will light up check engine light on dash and run for the rest of the day. Recently instead of randomly going into "limp mode" it will shut down engine while driving, sometimes while decelerating, sometimes wile accelerating sometimes coasting. usually will restart after parking and turning ignition off-on.
computer showed faults "minimum rail pressure" and "max rail pressure" although i believe the max pressure could have been from hand pumping the primer. drained fuel tank, cleaned strainer, replaced diesel filter, put new fuel in and bled system. Values checked against functioning iload and were the same, shows same fuel pressure at pump and rail on ODB. at the time had no fault codes and no engine light and would not start, then randomly decided to work.. it has once in the past not re started, until mysteriously re starting 2 hours later after disconnecting battery for 15 mins. Today it stalled 3 times in the morning and will not re start at all.
Submitted: 1 year ago.
Category: Australia Car
Expert:  Pete replied 1 year ago.

Hi my name is ***** ***** I will be happy to assist with this today.I saw that no one has replied with help and hope I can assist here.

If the fuel rail pressure sensor was not replaced or checked if this sensor is intermittently sending incorrect signals this may be causing the engine computer to turn off the injectors causing this no start.I have seen this as an issue on some models before with this sensor needing replaced.I would have this checked to see if yours needs replaced.

If it is o.k. There is a chance this is the injection pump itself at fault.I have seen the injection pump fail intermittently causing this issue here and if the values for pressure were not checked when the vehicle is acting up this should be done as this can help isolate if the pump or rail pressure sensor is at fault.

Let me know if you need anything else and feel free to rate my help if you like.Thanks Pete.