How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 24721
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

My 2013 Toyota Prado's audio unit has stopped working. All I

Customer Question

Hi. My 2013 Toyota Prado's audio unit has stopped working. All I get is either a bland screen, or a picture of the audio unit with a line across the bottom that looks like it's trying to load. Help!
Submitted: 1 year ago.
Category: Australia Car
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
From what you have described here this sounds like an internal electrical fault in the radio/audio unit itself.Since you have removed and reinstalled the fuse and this reset did not work this indicates the unit either needs removed and repaired to correct this here or removed and replaced.
Thanks Pete