How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 24656
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Holden Rodeo: , I have a TF Rodeo 2.2l Petrol. Eng check

Customer Question

Hi, I have a TF Rodeo 2.2l Petrol. Eng check light comes on from about 2000 rpm and about half throttle, looses some power. When turn off generally resets and starts without check light until load and revs, ECU has code 55 Eprom error, same as previous ECU with same symptom. On scanner shows that knock sensor regularly retarding 16 degrees even though has not got a knock sensor. Have tied earths together around ecu, KS wire is in wrong position according to 2 wiring diagrams but has very clean 0V. On dyno able to show that eng runs well until check light comes on and it does instantly loose probably 16 degrees and looses something like 20% power and runs harshly, as expected with such retarded timing. Wiring diagrams also show O2 sensor, has plug in exhaust. TPS and MAP smooth in operation. Are both O2 and KS meant to be on engine, is a single cab manual 2wd Rodeo. Thank you for your time. Peter
Submitted: 1 year ago.
Category: Australia Car
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.
I would inspect the wiring further to see if in the area the "hiccups" were noticed if there is any damaged wiring needing repaired at all.In allot of cases with a prom error code this can be wiring at fault if the computer is found o.k. or was replaced or may be a programming issue needing done by a dealer to correct this here.
Thanks Pete

Related Australia Car Questions