How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 24721
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

My 2001 truck sputters and stops when you press the accelerator

Customer Question

my 2001 truck sputters and stops when you press the accelerator sometimes. I have had it ot the checy dealer and they replaced the valves??? and charged me 1300 $ drove it home and on the way it started doing the same. took it back and they replaced a gasket??? I told them I felt like it was a fuel filter, fuel pump, fuel injector and they never checked it. do you think that is it? it goes for about 40 miles and themn when you turn it off and start to drive it shudders and almost dies.. you just stop, turn it off and wait a few minutes and then go again for a while. I'm going back today and want to know what to tell them
Submitted: 1 year ago.
Category: Australia Car
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.
From what you have described here this does sound like a fuel pump issue here with the pump losing pressure intermittently.If this was not checked into this should be done.
I have also seen crank sensor failure cause this as well.
Thanks Pete