How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis Your Own Question
Curtis
Curtis, Australia Car Mechanic
Category: Australia Car
Satisfied Customers: 1606
Experience:  Qualified Automotive Mechanic, LPG & Airconditioning Diagnostic Technician.
29271542
Type Your Australia Car Question Here...
Curtis is online now
A new question is answered every 9 seconds

Kia Sedona LX: just reading article on Radiator fan not

Customer Question

just reading article on Radiator fan not coming on - have followed all steps - but everything suggested has tested fine - is the issue now in the thermo sensor ? ( Kia Sorento ) - another issue that may be related is the temp gauge even when engine cold ( has not be started for days ) just putting keys to accessory power after a few seconds will have the temp gauge jump to mid range - even though cold ? but temp is cold - temp gauge then climbs from there until hits hottest temp but again coolant only feels warm / hot not boiling ? - thermo fans remain off ??

Submitted: 1 year ago.
Category: Australia Car
Customer: replied 1 year ago.
Update: Further testing - I disconnected the Water Temp Sensor - and the temp gauge on the dash remains in the middle range but thermo fans come straight on - If I run car for 10 mins with water sensor connected the temp gauge will climb to highest reading on the dash - but engine not hot - disconnecting the water temp sensor the temp gauge in dash will fall straight to middle range and thermo fans start ( should the temp gauge in dash fall to cold with the water temp sensor totally disconnected ? ) - reconnect water temp sensor - thermo fans stop - dash temp gauge climbs straight back to highest setting - despite the wrong reading car seems to run fine - I have two concerns - why are thermo fans not starting unless water temp sensor disconnected - also which is at fault - dash temp gauge or water temp sensor ? - would it be normal for the temp gauge to sit at middle temp with water temp sensor disconnected ? knowing this may better indicate if its a faulty water temp sensor or dash temp gauge ? - HELP GUYS !!!
Customer: replied 1 year ago.
Kia Sorento 2005 V6 BL

Related Australia Car Questions