How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Australia Car
Satisfied Customers: 24676
Experience:  Over 17 years diagnosing and repairing various model vehicles with some certifications and training.
14928985
Type Your Australia Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Toyota Coupe: I a Suraj working in Nissan as a Mechanic

Customer Question

Hi I a Suraj working in Nissan as a Mechanic but couldnt fix my friends car at my home. my friend brought his car(Toyota Coupe 1990) to change oil on his car and replace batry but by mistake I reverse connect(-terminal on + and + on Negetive) on Battry.After that their was bit of smoke on terminals and ECU fuse was gone.And now its dosent start and their is no Asseories on Dash Board.Sometime(not Always) it Cranks but dosent starts.what reason mite be?please let me know.
Suraj
Submitted: 1 year ago.
Category: Australia Car
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
Double check and make sure all fuses are good in all fuse boxes.If these are all o.k. the most common cause for this issue is a damaged ECU and may be more then one that has been damaged by this issue here.I suspect the engine ecu needs replaced as the reverse polarity has damaged it internally.
Thanks Pete