How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Audi
Satisfied Customers: 33416
Experience:  ASE Certified Tech
7276279
Type Your Audi Question Here...
Ron is online now
A new question is answered every 9 seconds

2009 Audi A4 2.0T. Alternator not charging battery. Replaced

Customer Question

2009 Audi A4 2.0T. Alternator not charging battery. Replaced with OEM Bosch ALT. and checked all fusable links. Still not charging battery. If I disconnect the B+ cable at the firewall, and test the alternator directly it charges 14.4volts. When I reconnect the B+ cable to the body at the firewall, alternator charge shows 12.3volts. Replaced alternator again with another unit, same problem. Battery is not charging.
Submitted: 4 months ago.
Category: Audi
Expert:  Ron replied 4 months ago.

Hello and thank you for your question,

The problem you are discribing with the charging system can be caused by any of the following,

  • Alternator — Faulty alternator/internal voltage regulator.
  • Alternator Wiring
  • Battery Auxiliary Fuse Box
    Are you able to do some testing If I send you the steps?
Customer: replied 4 months ago.
I can perform tests. I switched the connect around. And it charged the same. I sent alternator to be tested and showed 14+ volts. So I believe my alternator is working. Possible wiring issue or fuse box.
Expert:  Ron replied 4 months ago.

Okay, before you replace anything else run the steps I have enclosed in the link below.

https://dl.dropboxusercontent.com/u/104923897/Alternator%20Audi%20Jul%2028.pdf

See the wring diagram in this link for reference as well.

https://dl.dropboxusercontent.com/u/104923897/Audi%20Charge%20Jul%2028.pdf

Customer: replied 4 months ago.
Working on the testing still. This morning I walked up to the car, key was sitting on seat, but noticed dash was on ACC position. Weird, no key in ignition. This happened twice this week, any relation?
Expert:  Ron replied 4 months ago.

The position of the key should have no bearing on the alternator charging as long as the engine is running which would mean the key is in the run position..

Customer: replied 4 months ago.
I understand, but the key wasnt in the ignition and the dash showed the vehicle to be in position 2/ACC. Seems strange. I am still checking the car. I am busy it wont be until next week that I am finished.
Expert:  Ron replied 4 months ago.

Take you time, Im here if you need me.

Related Audi Questions