How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Technician
Category: Audi
Satisfied Customers: 24681
Experience:  Auto Technician with more then 17 years ecperience.Past ASE and other certifications.
14928985
Type Your Audi Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I have the 2008 Audi TT Roadster BPY whom lights on the

Customer Question

I have the 2008 Audi TT Roadster BPY whom lights on the climate control is blinking,also when the headlights is switch on the lights around the radio blinks as well, this started to happen after changing the Central electronics control module J517.
Submitted: 5 months ago.
Category: Audi
Expert:  peterpete190 replied 4 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

It is possible that the control module that you installed has an internal defect and may need replaced again under parts warranty from the facility it was purchased from or that it wasnt programmed/coded correctly for your model here.I would check and see if the programming or coding is correct at a dealer and if it is then I suspect it is at fault internally and needs parts warrantied from the facility you purchased it from to see if they will replace it at no charge to you.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 4 months ago.
Thanks for contacting me I am almost certain that something is missing from the programming because I have another module and after collecting the original code from it then putting it into the new I'm getting the same behavior.
Expert:  peterpete190 replied 4 months ago.

This does sound like a programming issue,either that or an issue with itself at fault needing replaced again.I would have a dealer check and perform any programming needed and see if this resolves the issue and if it does not then the control unit needs replaced again.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.

Thanks Pete

Customer: replied 4 months ago.
I would prefer you take me through step by step
Customer: replied 4 months ago.
I have the car overseas
Customer: replied 4 months ago.
Are you there?
Expert:  peterpete190 replied 4 months ago.

Unfortunately I dont have a way myself to go through this with you to test this.If you would like I can open your question up for others here to see if anyone else can assist further just let me know if this is something you would like to do.

Thanks Pete

Customer: replied 4 months ago.
Pete when I visited one of the online forums seeking help on this issue someone made reference to changing the value in byte 7 to 28 do you know of any way I can get this done or any dealer personnel who can assist.
Expert:  peterpete190 replied 4 months ago.

Unfortunately I dont know a way myself to get this done or a dealer tech here that may know this.I know this usually requires dealer equipment to get something like this done.

Customer: replied 4 months ago.
I can write to the module with my autel maxysis, may be all I would need is the code.
Expert:  peterpete190 replied 4 months ago.

The special coding has to come from a dealer and they have to contact their tech support to get this coding.Usually if they do not have the vehicle with them at the dealer they cannot get this programming/coding for you unfortunately.I have had to do this on other models and had to have the vehicle in front of me when I got the info from the tech support or programming department.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.

Thanks Pete

Customer: replied 4 months ago.
Pete can you get me info from tech support that's all I need to get this done. I would be very grateful.
Expert:  peterpete190 replied 4 months ago.

Unfortunately I do not have access to this myself.Would you like me to open your question back up here to see if anyone else can get this info,it maybe difficult to get unless you work at a dealer but someone else here may be able to help.Let me know.

Thanks Pete

Customer: replied 4 months ago.
I guess we don't have much of a choice.
Expert:  peterpete190 replied 4 months ago.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Related Audi Questions