How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Audi0405 Your Own Question
Audi0405, Technician
Category: Audi
Satisfied Customers: 10616
Experience:  10 years in Vw and Audi Field
Type Your Audi Question Here...
Audi0405 is online now
A new question is answered every 9 seconds

It shakes a little bit and the yellow engine light is on.

Customer Question

It shakes a little bit and the yellow engine light is on. When I connect an obd2 scanner, it reads $7E9, $7E8
JA: Do you have the trouble code? Do you have a code reader or scan tool?
Customer: No, I do not see a code, just the 2 words above
JA: What is the model/year of your Audi?
Customer: A4, 2007
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: no, I was annoyed because this is the third time this happens. I have beento the audi dealer twice for this problem, the last time less than 4 weeks ago
JA: Anything else you think the mechanic should know?
Customer: they supposedly changed the spark plug cables the first time. The second time they said the spark plug cables broke and changed them again, this time for free. The first time the error code was p0301
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Audi Mechanic about your situation and then connect you two.
Submitted: 3 months ago.
Category: Audi
Expert:  Audi0405 replied 3 months ago.

The your od2 scanner are not correct codes , is the check engine light blinking ? also what engine do you have ??

Customer: replied 3 months ago.
The code now is P0303. Previously it was P0301.
Audi A4; 2007; 2.0l
Expert:  Audi0405 replied 3 months ago.

Ok you have a misfire in cylinder # ***** this can be caused by several issues more then likely you have a issue with the coil in that cylinder these are very common to cause the issue if the coil has been replaced then i suggest for them to check compression in that cylinder . I hope this helps.

I hope this helps please dont forget to provide positive feedback for the help provided thank you

Related Audi Questions