How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Audi
Satisfied Customers: 1569
Experience:  Owner at Carolina Auto Service & Sales , 20 years Experience in Foreign & Domestic vehicles
45790705
Type Your Audi Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

My audi tt quatro 2004 is go to neutral while running and

Customer Question

my audi tt quatro 2004 is go to neutral while running and sometimes stay on 2nd gear
JA: How many miles are on the car? Have you noticed any fluid leaks lately?
Customer: 40000miles no oil leak
JA: Tell me a bit more about what's going on so he can help you best.
Customer: thats the only problem
JA: Are you hoping to fix this yourself?
Customer: yes
JA: Great! What have you tried so far?
Customer: nothing yet because i don't know where to start
JA: Is there anything else important you think the Audi Mechanic should know about your Audi?
Customer: nomore the car runs good
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Audi Mechanic about your situation and then connect you two.
Submitted: 6 months ago.
Category: Audi
Expert:  Chad Farhat replied 6 months ago.

Hi my name is ***** ***** will try to assist you

Have you scanned it and retrieve any codes ?

Customer: replied 6 months ago.
the po101 came out and nomore
Expert:  Chad Farhat replied 6 months ago.

no more it went away now and not throwing the check eng light again , i just want to be clear ?

the PO 0101 is a mass air flow sensor fault error.

The PCM detects that the actual MAF sensor frequency signal is not within a predetermined range of the calculated MAF value for more than 4.0 seconds.

Possible causes

1- defective mass air flow

3- Defective mass air flow harness connector

4- dirty air filter

5- defective map sensor

6- vaccuum leaks

when it goes in neutral while driving , what do you do to get back in gear , turn switch off then start again ?

Thanks

Expert:  Chad Farhat replied 6 months ago.

have you had a the tcm ( Transmission Control Module ) scanned or just the engine control module with a basic code reader or l at an advance auto parts ?

You need a capable scanner to access that , a dealer scanner or aftermarket one with the audi software to be able to communicate and retrieve codes .

who read the codes and using what scanner ?

other than the gear going to neutral , when it engaged and you driving is there any slippage that you feel?

Expert:  Chad Farhat replied 6 months ago.

its probably going in limp mode when this happens , but if you can answer my questions i will be able to narrow down for you

Expert:  Chad Farhat replied 6 months ago.

are u sure it is not a U 0101 code ? The letter the code starts with makes a difference ( P, C, B , or U)

because code U 0101 is lost communication with TCM ?

Customer: replied 6 months ago.
I'm sure po 101
Expert:  Chad Farhat replied 6 months ago.

ok good ,

so the P 101 is till on now , and this code came up and this gear problem started ?

if that is the case we need to start with mass air flow sensor , sensor connection , but tell me about how you got back into gear when it happens , by cycling igntion switch ?

.

Customer: replied 6 months ago.
Check engine came out 4days ago but the neutra issue maybe 3 weeks i need to turn off ignition and back on that way it's work
Expert:  Chad Farhat replied 6 months ago.

TT Bulletin Number: 0401 2002 AUDI ALLROAD QUATTRO

P101 ,P102 ,P103..

These are the symptoms

ENGINE MAY STALL AT IDLE WHEN TRANSMISSION IS SHIFTED FROM NEUTRAL/PARK TO DRIVE OR REVERSE.

The P101 code came on because of the transmission problem .

Of course I can confirm more If you have a scanner , I believe if you clear code , the po101 will come back as long as the gear problem keeping happening it might take some time for the computer to decide to throw the check engine light , u need some many ignition cycles for it to see the fault and throw the light on

You can have the mass airflow tested , but the code came after 3 weeks of gear failure .

Expert:  Chad Farhat replied 6 months ago.

when you drive it after the gear going to neutral and you cycled the switch does the car drive normal no lack of power and full acceleration ?

Expert:  Chad Farhat replied 6 months ago.

Its common failure on the transmission in the TT , with the symptoms you are describing

I would suggest to take it to a transmission specialist and have it checked ,

The transmission Rebuild units for your car year model are more available then in the past & the price went down on them if you end up needing one .

Expert:  Chad Farhat replied 6 months ago.

Hope that was helpful to you

A POSITIVE RATING IS MUCH APPRECIATED

You can come back to this post even after you rate me for any follow up questions you may have for me on this issue.

Thank You

Chad F

Customer/p>
Expert:  Chad Farhat replied 6 months ago.

hi , what you end up doing with it

Related Audi Questions