How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Eric Your Own Question
Eric, Automotive Repair Shop Manager
Category: Audi
Satisfied Customers: 29727
Experience:  Automotive Repair Shop Manager, Technician/JA Mentor
Type Your Audi Question Here...
Eric is online now
A new question is answered every 9 seconds

Audi A6 Quattro: I have a 1999 Audi A6 2.8 Quattro automatic

Customer Question

I have a 1999 Audi A6 2.8 Quattro automatic with a seldom working speedometer. I replaced the vehicle speed sensor and seemed to work for a short time. I used my vag-com and have done the gauge sweep test and the speedometer and entire gauge cluster work fine. I don't know what else it could be? Any help or ideas are appreciated!
Submitted: 6 months ago.
Category: Audi
Expert:  Eric replied 6 months ago.
HI,I am sorry that you havent been helped yet. I just came online and saw your question. Ok, on a test drive with scan tool hooked on and showing live data, when the speedometer is not registering correctly, is the scan tool showing correct mph? Also, any present fault codes? And finally, I will need the vin number to pull the schematics
Customer: replied 6 months ago.
While I was driving around my friend was monitoring the computer. He said the speedometer reading was showing mainly zero with an occasional spike in some random high number reading. The only reading that showed speed on the vag-com was wheel sensor. The only fault code I have is: 16885 - Vehicle Speed Sensor P0501 - 35-00 - Implausible Signal
the vin # *****: WAUBA24B0XN093707
Expert:  Eric replied 6 months ago.
HI, Ok, so still not getting a signal from the vss. Do you have the VAG test box that connects to the ecm connector
Customer: replied 6 months ago.
No, only to the OBDII connector.
Expert:  Eric replied 6 months ago.
HI,The only testing I know to determine whether it is the wiring harness or the ecm is with the VAG tester box. I will opt out and see if another expert can help on this

Related Audi Questions