How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary, ASE Certified Technician
Category: Audi
Satisfied Customers: 684
Experience:  Senior Technician
Type Your Audi Question Here...
Gary is online now
A new question is answered every 9 seconds

My name is ***** ***** it's regarding red oil pressure light

Customer Question

My name is ***** ***** it's regarding red oil pressure light 2007 Audi S4
JA: Thanks. Can you give me any more details about your issue?
Customer: I did an change replace the sensor. And the code keeps coming up when I press the check button is there anyway I can clear it and then test it to see if the red light comes on again also my antifreeze light is yellow flashing when I press the check button
JA: OK got it. Last thing — Audi Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 6 months ago.
Category: Audi
Expert:  Gary replied 6 months ago.
Hi there,When does the light come on, only at idle?How many miles on this engine?I would be measuring the oil pressure with a workshop gauge.Gary
Customer: replied 6 months ago.
Can you run me through how do I use an air compressor on the oil pressure to test it also the light comes on whenever I about 4000 RPM or whenever I get on it there's 110,000 miles motor
Expert:  Gary replied 6 months ago.
Ok, first up I would not drive it until you prove the engine is ok.You need a workshop style oil pressure gauge, or even a cheaper mechanical gauge to screw in place of the sensor.Is the oil level correct?Does it make any noise when the light comes on?I would take a bet your issue is not sensor or ECM related.Gary
Expert:  Gary replied 6 months ago.
Hi again,You could have an oil pump supply issue, blocked screen etc.I hope my advice has been of assistance to you.Regards Gary

Related Audi Questions