How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask gomi_otaku Your Own Question
gomi_otaku
gomi_otaku, Technician
Category: Audi
Satisfied Customers: 3379
Experience:  VW certified technician, Chicago VW/Audi Training Center, Seattle VW/Audi Academy
12249065
Type Your Audi Question Here...
gomi_otaku is online now
A new question is answered every 9 seconds

I have a 2012 audi s4. it misfires on cycinders 4,5,6(bank

Customer Question

I have a 2012 audi s4. it misfires on cycinders 4,5,6(bank 2) when I go over about 4000 rpms. I have to restart my car and it will run normal again (until i go over 4000rpms again). I have a APR stage 2 tune, with cold air intake installed and the smaller pulley. It always ran fine with this tune, I have switched the tune back to factory and it still misfires the same way. I have changed 2 injectors, had the carbon cleaned, changed the timing position sensor, and MAF sensor. I changed spark plugs, and 1 new coil pack and switched out around the 3 cylinders to see if it would help. I run 93 octane, i also did a sea foam treatment both in vacuum lines and gas tank. when I did it in the vacuum lines I feel like it helped a little actually which is weird. it seemed to misfire closer to 4500 rpms instead of 4000. I have a vag-com and this is the codes I have received from it. I also logged my misfires to see which cylinder it was starting on and it seems to misfire first and way more on cyl
Submitted: 1 year ago.
Category: Audi
Customer: replied 1 year ago.
Sunday,13,September,2015,17:36:20:29595
VCDS Version: Release 14.10.2
Ross-Tech: Home
Address 01: Engine Labels: 06E-907-551-CAK.clb
Control Module Part Number: 8K0 907 551 D HW: 8K0 907 551 A
Component and/or Version: 3.0T SIMOS84 H08 0003
Software Coding:(###) ###-####240F0128
Work Shop Code: WSC 06324 000 00000
ASAM Dataset: EV_ECM30TFS0218K0907551D 001003 (AU48)
ROD: EV_ECM30TFS0218K0907551D.rod
VCID: 326B5EA0655CFAB1A8B-8067
7 Faults Found:
6353 - Cylinder 4
P0304 00 [236] - Misfire Detected
MIL ON - Intermittent - Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 4
Mileage: 95237 km
Date: 2015.08.10
Time: 16:40:27
6355 - Cylinder 6
P0306 00 [236] - Misfire Detected
MIL ON - Intermittent - Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 17
Mileage: 95236 km
Date: 2015.08.10
Time: 16:40:24
6354 - Cylinder 5
P0305 00 [236] - Misfire Detected
MIL ON - Intermittent - Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 21
Mileage: 95236 km
Date: 2015.08.10
Time: 16:40:24
6371 - Random/Multiple Cylinder Misfire Detected
P0300 00 [096] - -
Intermittent - Not Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 12
Mileage: 95236 km
Date: 2015.08.10
Time: 16:40:24
6190 - Oxygen (Lambda) Sensor B2 S2
P0157 00 [032] - Signal too Low
Intermittent - Not Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 1
Mileage: 96724 km
Date: 2015.08.25
Time: 09:35:07
6095 - Catalyst System; Bank 2
P0430 00 [237] - Efficiency Below Threshold
MIL ON - Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 11
Mileage: 95269 km
Date: 2015.08.11
Time: 09:05:24
7948 - Cylinder Disabling
P130A 00 [044] - -
Intermittent - Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 23
Mileage: 95236 km
Date: 2015.08.10
Time: 16:40:24
Customer: replied 1 year ago.
Idk if the full text was on my explanation or not but during logging, it start misfiring on cylinder 5 and misfires a ton more than 4 and 6
Expert:  gomi_otaku replied 1 year ago.

I would check the intake hoses, to make sure they are all tight. It sounds like you are developing a leak under pressure on that bank. Either that, or your timing is starting to stray off on that bank, maybe check to be sure the tensioner is OK.

Customer: replied 1 year ago.
I believe I may have found my issue. that second o2 sensor's ohms is way too high, right? 1719ohms!? it says bank 2 probe 2. where would that sensor be located, if its the issue? could that lambda probe cause misfires on one bank?
Expert:  gomi_otaku replied 1 year ago.

The rear O2 sensors monitor the operation of your catalytic converter. More than likely the sensor is showing a fault due to the rich in burned mixture it keeps seeing, and may also be getting covered in a layer of sooty residue from partially or unburned fuel.