How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask AudiDoc Your Own Question
AudiDoc
AudiDoc, Independent Audi Shop Owner
Category: Audi
Satisfied Customers: 1695
Experience:  I've been working on Audis since I was 18 and own an independent Audi repair and performance shop
14582033
Type Your Audi Question Here...
AudiDoc is online now
A new question is answered every 9 seconds

2007 audi a4 2.0t have some communication issues,some

Customer Question

2007 audi a4 2.0t have some communication issues,some modules like the pcm,abs,airbag,ipc,radio have communication but some others dont like the ac module,roof top,comfort moule etc.
Submitted: 1 year ago.
Category: Audi
Expert:  Billy replied 1 year ago.
Hello and Welcome! I'm Billy and i will assist you with your inquiry. Feel free to ask if any further info is needed.
My apologies for the delay, thank you for your patience.
What are the issues, and what codes are you getting on the modules?
what problems or symptoms are you getting apart from the fault codes?
Customer: replied 1 year ago.
It started with the roof top you would press the open button and it would open just it bit. I tried scanning the roof top module but no communication,checked the fuses checked okay. Decided to check the module and opened it found water in it and the board had short circuit. Replace the module and does the same thing and no communication. Thats when i noticed that i did even have communication with other modules comfort,climate,pwr windows,steering,pwr seats,etc.
Expert:  Billy replied 1 year ago.
Hello,
This should be located behind the side trim on passenger side.
If there is water ingress, then there would be water in other places (inside the car), accordingly, where other modules checked for water, corrosion etc..?
and was the roof left open at some point (under rain etc..) to cause this?
Customer: replied 1 year ago.
I dont know if the vehicle was left with the roof top open. All i know I'm trying to find the solution to the problem. I did check the k lines wiring for short and open but did not found any problems, also I disconnected the modules one by one to see if i have communication but know luck and also did bypass to one module in k lines but no communication. Running out of ideas.
Expert:  Billy replied 1 year ago.
Hello again,
which scan tool are you using?
are you getting communication fault codes? or just unable to communicate using the scan tool?
are the modules (since they were checked and disconnected) getting power supply?
Customer: replied 1 year ago.
I'm using a Launch pad X431 I can communicate with these modules PCM,SRS,ABS,TCM,IPC,RADIO/NAV,TEL
if these modules have codes is there a possibility that maybe one or two codes are affecting the communication to other modules.
Expert:  Billy replied 1 year ago.
Hello,
Yes, there is that possibility, there is also the possibility of CAN codes, and there is the possibility of protocol compatibility.
What are the codes you are getting?