How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, Master Technician
Category: Audi
Satisfied Customers: 17198
Experience:  ASE MASTER CERTIFICATION, AA DEGREE AUTOMOTIVE/DIESEL
1627031
Type Your Audi Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

Audi A4 Quattro: I am working on 2008 audi A4 quattro. Lacks

Customer Question

Hi I am working on 2008 audi A4 quattro. Lacks power on takeoff and sets code 00022 almost immediately. Checked and replaced timing belt and chain. Checked oil solenoid. Cam and crank sensors are in sync. Any suggestions would help. Thanks Brian
Submitted: 1 year ago.
Category: Audi
Expert:  FIXITMAN replied 1 year ago.
Hello, my name is Bobby. Thank you for the question. Can you tell me how many miles are on the car. Are you sure about the code number?
Customer: replied 1 year ago.
The car has 133740 miles. The code is 00022 incorrect correlation, or P0016.
Expert:  FIXITMAN replied 1 year ago.
Thank you. ***** ask one more question. When you clear the code how long does it take for the light to come back on?
Customer: replied 1 year ago.
Within about 1 min of running at idle.
Expert:  FIXITMAN replied 1 year ago.
Thank you. If you are using a computer scan tool and it is showing the cams in time but yet it is still throwing the correlation code then there is either an issue within the module or you may have a timing actuator issue. Has the vehicle ever been in an accident?
Customer: replied 1 year ago.
I don't know about the accident. When referring to the actuator do you mean the solenoid or the cam actuator on camshaft. I did try yesterday disconnecting solenoid code did not set . The vehicle seems to have no power till about 3000 rpm. I will try to drive vehicle with solenoid disconnected. Its the lack of power thats keeps me thinking mechanical. I thought maybe there is something I was missing. Do you know if PCM should pulse ground to solenoid at idle?
Expert:  FIXITMAN replied 1 year ago.
I am referring to the actuator on the cam. As for when it occurs, it should not do it at idle. I ask about the accident because it may have a faulty or misprogrammed computer.
Customer: replied 1 year ago.
I did replace the actuator when replaceing the chain and tensioner. The vehicle was purchased at a auction by a used car dealer. Now it is my headache. Thanks for the suggestions. Do you think the next step should be reprogram the computer?
Expert:  FIXITMAN replied 1 year ago.
If everything appears to be in time then I would have the computer programmed to see if the programming is off.
Customer: replied 1 year ago.
Sorry for the hold up waited for autologic to send download. Reprogrammed computer, code still comes back. Any other suggestions? Thanks Brian
Expert:  FIXITMAN replied 1 year ago.
Did you reprogram the vehicles main computer? Did they give you a program number?